summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/fbgetty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/fbgetty')
-rw-r--r--net-dialup/fbgetty/Manifest1
-rw-r--r--net-dialup/fbgetty/fbgetty-0.1.698-r1.ebuild29
-rw-r--r--net-dialup/fbgetty/files/fbgetty-0.1.698-gcc41.patch64
-rw-r--r--net-dialup/fbgetty/metadata.xml5
4 files changed, 99 insertions, 0 deletions
diff --git a/net-dialup/fbgetty/Manifest b/net-dialup/fbgetty/Manifest
new file mode 100644
index 000000000000..0ad17d7be68a
--- /dev/null
+++ b/net-dialup/fbgetty/Manifest
@@ -0,0 +1 @@
+DIST fbgetty-0.1.698.tar.gz 279751 SHA256 332cbffa7c489b39a7d13d12d581c27dfc57ba098041431a6845b44785cf2d35 SHA512 942304ac00ecfaad59419a0994331e59d91269ee015e3bd38faa85db0b205e6e88e1958b65e503f59b81f050a1e110aeea6534eecb3ba010096a6b5173fd1ac5 WHIRLPOOL a2a6cfd2c1cadc60e941922229cfd642f054a3221fb95dad2d63f4d44f8ebd7268fc7761b36d926b591433e4e9da3e4ea49dee6ba499ee2dfb446232c960cd37
diff --git a/net-dialup/fbgetty/fbgetty-0.1.698-r1.ebuild b/net-dialup/fbgetty/fbgetty-0.1.698-r1.ebuild
new file mode 100644
index 000000000000..a52f622391b2
--- /dev/null
+++ b/net-dialup/fbgetty/fbgetty-0.1.698-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="An extended getty for the framebuffer console"
+HOMEPAGE="http://projects.meuh.org/fbgetty/"
+SRC_URI="http://projects.meuh.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+
+ epatch_user
+}
+
+src_install() {
+ default
+
+ docompress -x "/usr/share/doc/${PF}/examples"
+ insinto "/usr/share/doc/${PF}/examples"
+ doins examples/{issue.*,inittab.*}
+}
diff --git a/net-dialup/fbgetty/files/fbgetty-0.1.698-gcc41.patch b/net-dialup/fbgetty/files/fbgetty-0.1.698-gcc41.patch
new file mode 100644
index 000000000000..a9722f12c115
--- /dev/null
+++ b/net-dialup/fbgetty/files/fbgetty-0.1.698-gcc41.patch
@@ -0,0 +1,64 @@
+diff -Nru fbgetty-0.1.698.orig/include/fbgetty/generated/fgoptions.awk fbgetty-0.1.698/include/fbgetty/generated/fgoptions.awk
+--- fbgetty-0.1.698.orig/include/fbgetty/generated/fgoptions.awk 2001-07-11 23:01:15.000000000 +0300
++++ fbgetty-0.1.698/include/fbgetty/generated/fgoptions.awk 2007-10-27 11:29:50.000000000 +0300
+@@ -45,8 +45,7 @@
+ name = $3;
+ type = $2;
+
+- printf("#define OFFSET_%s (offsetof(struct fbgetty_options_t, %s))\n", name, name);
+- printf(" %s %s;\n\n", type, name);
++ printf(" %s %s;\n", type, name);
+ }
+
+ END {
+diff -Nru fbgetty-0.1.698.orig/src/options.c fbgetty-0.1.698/src/options.c
+--- fbgetty-0.1.698.orig/src/options.c 2001-12-17 22:55:42.000000000 +0200
++++ fbgetty-0.1.698/src/options.c 2007-10-27 11:32:53.000000000 +0300
+@@ -27,7 +27,7 @@
+ */
+
+ #include <fbgetty/global.h>
+-
++#include <stddef.h>
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -141,7 +141,7 @@
+ #define ENV_BINARY 0x04
+ #define ENV_LEDS 0x08
+
+-#define ENV_ENTRY(name, type, ptr) { name, type, OFFSET_ ## ptr }
++#define ENV_ENTRY(name, type, ptr) { name, type, offsetof(struct fbgetty_options_t, ptr) }
+
+ static struct env_entry
+ {
+@@ -899,20 +899,20 @@
+ }
+ merge_option_list[] =
+ {
+- { OFFSET_tty_device , MERGE_STR, NULL, -1 },
++ { offsetof(struct fbgetty_options_t, tty_device) , MERGE_STR, NULL, -1 },
+ #ifdef USE_FRAME_BUFFER
+- { OFFSET_fb_device, MERGE_STR, NULL, -1 },
++ { offsetof(struct fbgetty_options_t, fb_device), MERGE_STR, NULL, -1 },
+ #endif
+
+- { OFFSET_login_program, MERGE_STR, LOGIN_PROGRAM, -1 },
+- { OFFSET_login_prompt, MERGE_STR, LOGIN_PROMPT, -1 },
+- { OFFSET_issue_filename, MERGE_STR, ISSUE_FILE, -1 },
++ { offsetof(struct fbgetty_options_t, login_program), MERGE_STR, LOGIN_PROGRAM, -1 },
++ { offsetof(struct fbgetty_options_t, login_prompt), MERGE_STR, LOGIN_PROMPT, -1 },
++ { offsetof(struct fbgetty_options_t, issue_filename), MERGE_STR, ISSUE_FILE, -1 },
+
+- { OFFSET_login_timeout, MERGE_INT, NULL, LOGIN_TIMEOUT },
+- { OFFSET_issue_refresh, MERGE_INT, NULL, ISSUE_REFRESH },
+- { OFFSET_screen_clear, MERGE_INT, NULL, TRUE },
++ { offsetof(struct fbgetty_options_t, login_timeout), MERGE_INT, NULL, LOGIN_TIMEOUT },
++ { offsetof(struct fbgetty_options_t, issue_refresh), MERGE_INT, NULL, ISSUE_REFRESH },
++ { offsetof(struct fbgetty_options_t, screen_clear), MERGE_INT, NULL, TRUE },
+
+- { OFFSET_leds, MERGE_INT, NULL, 0 },
++ { offsetof(struct fbgetty_options_t, leds), MERGE_INT, NULL, 0 },
+ { 0, 0, NULL, -1 }
+ };
+
diff --git a/net-dialup/fbgetty/metadata.xml b/net-dialup/fbgetty/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/fbgetty/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>