summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/gnuradius
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/gnuradius')
-rw-r--r--net-dialup/gnuradius/Manifest1
-rw-r--r--net-dialup/gnuradius/files/gnuradius-1.5-gcc41.patch23
-rw-r--r--net-dialup/gnuradius/files/gnuradius-1.5-implicit-decl.patch66
-rw-r--r--net-dialup/gnuradius/files/gnuradius-1.6.1-qa-false-positives.patch27
-rw-r--r--net-dialup/gnuradius/gnuradius-1.6.1-r1.ebuild69
-rw-r--r--net-dialup/gnuradius/metadata.xml5
6 files changed, 191 insertions, 0 deletions
diff --git a/net-dialup/gnuradius/Manifest b/net-dialup/gnuradius/Manifest
new file mode 100644
index 000000000000..82da391db542
--- /dev/null
+++ b/net-dialup/gnuradius/Manifest
@@ -0,0 +1 @@
+DIST radius-1.6.1.tar.gz 2602368 SHA256 3053b670704aa2fbcb6235d9a8f2e31329849faa5eca8c2b9a55cb35ff0993d0 SHA512 55a3273075eb74ad708b8808ec56e7df24cd442b6d36070ab0dc076136919bf18beb24cb3ee2dcd33d672f983e9439f5cd60932c64b1e490111726eecc43fcf0 WHIRLPOOL 1a7b12d3767697235fa5e040cfb14a1f0334504deb08cae83d7e4af4740d24dce2bc707b486af1bd2a0a41b0643d67f68f9cc60d8ca66c75103ac0c8e758d60e
diff --git a/net-dialup/gnuradius/files/gnuradius-1.5-gcc41.patch b/net-dialup/gnuradius/files/gnuradius-1.5-gcc41.patch
new file mode 100644
index 000000000000..a269dfc993b5
--- /dev/null
+++ b/net-dialup/gnuradius/files/gnuradius-1.5-gcc41.patch
@@ -0,0 +1,23 @@
+diff -Nru radius-1.5.orig/include/radiusd.h radius-1.5/include/radiusd.h
+--- radius-1.5.orig/include/radiusd.h 2007-06-27 15:54:21.000000000 +0300
++++ radius-1.5/include/radiusd.h 2007-07-14 09:17:16.000000000 +0300
+@@ -340,7 +340,6 @@
+ extern int max_threads;
+ extern int num_threads;
+ #ifdef USE_SERVER_GUILE
+-extern unsigned scheme_gc_interval;
+ extern u_int scheme_task_timeout;
+ #endif
+ #ifdef USE_SNMP
+diff -Nru radius-1.5.orig/radiusd/log.c radius-1.5/radiusd/log.c
+--- radius-1.5.orig/radiusd/log.c 2007-06-27 15:54:22.000000000 +0300
++++ radius-1.5/radiusd/log.c 2007-07-14 09:17:16.000000000 +0300
+@@ -185,7 +185,7 @@
+ if (rewrite_invoke(String,
+ &val,
+ hook_name,
+- req,
++ (grad_request_t *)req,
+ "isi",
+ req->code,
+ grad_nas_request_to_name(req,
diff --git a/net-dialup/gnuradius/files/gnuradius-1.5-implicit-decl.patch b/net-dialup/gnuradius/files/gnuradius-1.5-implicit-decl.patch
new file mode 100644
index 000000000000..2e4b509b9c2d
--- /dev/null
+++ b/net-dialup/gnuradius/files/gnuradius-1.5-implicit-decl.patch
@@ -0,0 +1,66 @@
+diff -Nru radius-1.5.orig/lib/getgr.c radius-1.5/lib/getgr.c
+--- radius-1.5.orig/lib/getgr.c 2007-07-14 09:23:17.000000000 +0300
++++ radius-1.5/lib/getgr.c 2007-07-14 09:20:52.000000000 +0300
+@@ -23,6 +23,7 @@
+ #endif
+ #include <sys/types.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <grp.h>
+
+ #include <radius/mem.h>
+diff -Nru radius-1.5.orig/lib/getpw_r.c radius-1.5/lib/getpw_r.c
+--- radius-1.5.orig/lib/getpw_r.c 2007-07-14 09:23:17.000000000 +0300
++++ radius-1.5/lib/getpw_r.c 2007-07-14 09:20:52.000000000 +0300
+@@ -24,6 +24,7 @@
+
+ #include <sys/types.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <pwd.h>
+
+ LOCK_DECLARE(lock)
+diff -Nru radius-1.5.orig/lib/numtostr.c radius-1.5/lib/numtostr.c
+--- radius-1.5.orig/lib/numtostr.c 2007-06-27 15:53:52.000000000 +0300
++++ radius-1.5/lib/numtostr.c 2007-07-14 09:23:56.000000000 +0300
+@@ -22,6 +22,7 @@
+
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <string.h>
+ #include "intprops.h"
+
+ size_t
+diff -Nru radius-1.5.orig/radscm/rscm_lib.c radius-1.5/radscm/rscm_lib.c
+--- radius-1.5.orig/radscm/rscm_lib.c 2007-07-14 09:23:17.000000000 +0300
++++ radius-1.5/radscm/rscm_lib.c 2007-07-14 09:20:52.000000000 +0300
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <libguile.h>
++#include <string.h>
+ #include <radius/radius.h>
+ #include <radius/radscm.h>
+
+diff -Nru radius-1.5.orig/radscm/rscm_utmp.c radius-1.5/radscm/rscm_utmp.c
+--- radius-1.5.orig/radscm/rscm_utmp.c 2007-07-14 09:23:17.000000000 +0300
++++ radius-1.5/radscm/rscm_utmp.c 2007-07-14 09:20:52.000000000 +0300
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
+
+diff -Nru radius-1.5.orig/scripts/mktypes.c radius-1.5/scripts/mktypes.c
+--- radius-1.5.orig/scripts/mktypes.c 2007-07-14 09:23:17.000000000 +0300
++++ radius-1.5/scripts/mktypes.c 2007-07-14 09:20:52.000000000 +0300
+@@ -25,6 +25,7 @@
+ #ifdef HAVE_STDINT_H
+ # include <stdint.h>
+ #endif
++#include <stdio.h>
+
+ #ifndef DEF_AUTH_PORT
+ # define DEF_AUTH_PORT 1812
diff --git a/net-dialup/gnuradius/files/gnuradius-1.6.1-qa-false-positives.patch b/net-dialup/gnuradius/files/gnuradius-1.6.1-qa-false-positives.patch
new file mode 100644
index 000000000000..8f48ff67260c
--- /dev/null
+++ b/net-dialup/gnuradius/files/gnuradius-1.6.1-qa-false-positives.patch
@@ -0,0 +1,27 @@
+--- a/radscripts/Makefile.in
++++ b/radscripts/Makefile.in
+@@ -854,19 +854,19 @@
+
+
+ radctl: $(srcdir)/radctl.m4
+- $(M4) $(M4_DEFINES) $(srcdir)/radctl.m4 > radctl
++ @$(M4) $(M4_DEFINES) $(srcdir)/radctl.m4 > radctl
+
+ radgrep: $(srcdir)/radgrep.m4
+- $(M4) $(M4_DEFINES) $(srcdir)/radgrep.m4 > radgrep
++ @$(M4) $(M4_DEFINES) $(srcdir)/radgrep.m4 > radgrep
+
+ radping: $(srcdir)/radping.m4
+- $(M4) $(M4_DEFINES) $(srcdir)/radping.m4 > radping
++ @$(M4) $(M4_DEFINES) $(srcdir)/radping.m4 > radping
+
+ radauth: $(srcdir)/radauth.m4
+- $(M4) $(M4_DEFINES) $(srcdir)/radauth.m4 > radauth
++ @$(M4) $(M4_DEFINES) $(srcdir)/radauth.m4 > radauth
+
+ builddbm: $(srcdir)/builddbm.m4
+- $(M4) $(M4_DEFINES) $(srcdir)/builddbm.m4 > builddbm
++ @$(M4) $(M4_DEFINES) $(srcdir)/builddbm.m4 > builddbm
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net-dialup/gnuradius/gnuradius-1.6.1-r1.ebuild b/net-dialup/gnuradius/gnuradius-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..4f938c5e0ca6
--- /dev/null
+++ b/net-dialup/gnuradius/gnuradius-1.6.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib pam
+
+MY_P="${P#gnu}"
+
+DESCRIPTION="GNU radius authentication server"
+HOMEPAGE="http://www.gnu.org/software/radius/radius.html"
+SRC_URI="mirror://gnu/radius/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="
+ dbm debug guile mysql nls odbc postgres readline snmp static-libs
+"
+
+DEPEND="
+ !net-dialup/cistronradius
+ !net-dialup/freeradius
+ dbm? ( sys-libs/gdbm )
+ guile? ( >=dev-scheme/guile-1.4 )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ postgres? ( dev-db/postgresql[server] )
+ readline? ( sys-libs/readline )
+ snmp? ( net-analyzer/net-snmp )
+ virtual/pam
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qa-false-positives.patch
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --enable-client \
+ --enable-pam \
+ --enable-server \
+ --libdir=/usr/$(get_libdir) \
+ --with-pamdir=/usr/$(getpam_mod_dir) \
+ $(use_enable dbm) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable snmp) \
+ $(use_enable static-libs static) \
+ $(use_with guile) \
+ $(use_with guile server-guile) \
+ $(use_with mysql) \
+ $(use_with odbc) \
+ $(use_with postgres) \
+ $(use_with readline)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/net-dialup/gnuradius/metadata.xml b/net-dialup/gnuradius/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/gnuradius/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>