summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-20 13:04:59 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-20 13:10:55 +0200
commit14a8fb0b70c1bee6698e5d0e5c1eedf1e8dcaa0e (patch)
tree085ca35f8baf445a830784f617363948d78f5380 /net-dialup/mgetty
parentx11-drivers/nvidia-drivers: Version 410.57. (diff)
downloadgentoo-14a8fb0b70c1bee6698e5d0e5c1eedf1e8dcaa0e.tar.gz
gentoo-14a8fb0b70c1bee6698e5d0e5c1eedf1e8dcaa0e.tar.bz2
gentoo-14a8fb0b70c1bee6698e5d0e5c1eedf1e8dcaa0e.zip
net-dialup/mgetty: Version 1.2.1.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-dialup/mgetty')
-rw-r--r--net-dialup/mgetty/Manifest1
-rw-r--r--net-dialup/mgetty/files/mgetty-1.2.1-Lucent.c.patch16
-rw-r--r--net-dialup/mgetty/files/mgetty-1.2.1-gentoo.patch154
-rw-r--r--net-dialup/mgetty/mgetty-1.2.1.ebuild185
4 files changed, 356 insertions, 0 deletions
diff --git a/net-dialup/mgetty/Manifest b/net-dialup/mgetty/Manifest
index 2f1f5770f194..87519dc4c6bf 100644
--- a/net-dialup/mgetty/Manifest
+++ b/net-dialup/mgetty/Manifest
@@ -1 +1,2 @@
+DIST mgetty-1.2.1.tar.gz 1077415 BLAKE2B 09d48c6cb7917a3dbbfc97c1d32ce43b9a3e64e8a44c8a3a7bfdd168421c287357a9d43504fb4d1b354ffb0f8e2a9c52b56ac3464f196f56064d96a7651e0d6e SHA512 2a82dfb782044d9daf8d41158fa10e991dbd7bd37ab43ea44422166554dd790e989ac49e4ff471d168d1cbb49edc5bedb8762ab61884e4653650686d1bbc2a9b
DIST mgetty1.1.37-Jun05.tar.gz 1057939 BLAKE2B de22751e72d72d19293794739c29ed115a6810cd7d57c07228526817120898ca597ba35afad36c324562c220ab67dd44655247ac46a2d6612c704557f3ec149d SHA512 577d740c7d209b830bf8e783bf71edb666cb8bbfe8e7dceaa51dda6095d88724715394bcbd24eacfb1c377999f5779b547a7ec79cd9cdc13de6de18c4d857188
diff --git a/net-dialup/mgetty/files/mgetty-1.2.1-Lucent.c.patch b/net-dialup/mgetty/files/mgetty-1.2.1-Lucent.c.patch
new file mode 100644
index 000000000000..ac73bea808c0
--- /dev/null
+++ b/net-dialup/mgetty/files/mgetty-1.2.1-Lucent.c.patch
@@ -0,0 +1,16 @@
+--- a/voice/libvoice/Lucent.c
++++ b/voice/libvoice/Lucent.c
+@@ -96,6 +96,13 @@
+ if (voice_command("AT+VLS=0", "OK") != VMA_USER_1)
+ lprintf(L_WARN, "can't deselect all input/output devices");
+
++ /* the Lucent chips DO support Caller ID, this command is OK */
++ /* Just borrowed from the V253modem.c file */
++ /* enable callerid (if supported) and setformat */
++ if (voice_command("AT+VCID=1", "OK") != VMA_USER_1)
++ lprintf(L_WARN, "can't set caller ID output");
++ /* mgetty supports formated callerid output */
++
+ voice_modem_state = IDLE;
+ return(OK);
+ }
diff --git a/net-dialup/mgetty/files/mgetty-1.2.1-gentoo.patch b/net-dialup/mgetty/files/mgetty-1.2.1-gentoo.patch
new file mode 100644
index 000000000000..fd46ff23ed46
--- /dev/null
+++ b/net-dialup/mgetty/files/mgetty-1.2.1-gentoo.patch
@@ -0,0 +1,154 @@
+--- a/callback/Makefile
++++ b/callback/Makefile
+@@ -37,7 +37,7 @@
+ # install programs
+ #
+ install: all
+- $(INSTALL) -s -m 700 -o root callback $(SBINDIR)
+- $(INSTALL) -s -m 4711 -o root ct $(BINDIR)
++ $(INSTALL) -m 700 -o root callback $(SBINDIR)
++ $(INSTALL) -m 4711 -o root ct $(BINDIR)
+
+ # source modules
+--- a/doc/mgetty.texi-in
++++ b/doc/mgetty.texi-in
+@@ -19,6 +19,11 @@
+ Copyright @copyright{} 1993-2005 Gert Doering
+ @end ifinfo
+
++@dircategory User
++@direntry
++* MGETTY: (mgetty). Modem+Voice+Fax utilities
++@end direntry
++
+ @titlepage
+ @sp 6
+ @center @titlefont{mgetty+sendfax}
+--- a/fax/faxspool.in
++++ b/fax/faxspool.in
+@@ -390,7 +390,7 @@
+
+ #
+ # convert pdf data
+-# needs GNU GhostScript and Adobe acroread installed.
++# needs GNU GhostScript installed.
+ # For driver selection, see definition of GS_DRIVER_{HI,LO} above.
+ #
+ # contributed by mfvm@gmx.de (Michael Fischer v. Mollard)
+@@ -401,7 +401,7 @@
+ test X$3 = X-n && driver="$GS_DRIVER_LO"
+
+ cat $1 |
+- acroread -toPostScript |
++ pdf2ps -sOutputFile=- - |
+ gs $driver -sOutputFile=$2%03d -dNOPAUSE -q -dSAFER -
+ }
+
+--- a/frontends/X11/viewfax/Makefile
++++ b/frontends/X11/viewfax/Makefile
+@@ -61,7 +61,7 @@
+ g3hack: g3hack.c
+
+ install: viewfax
+- $(INSTALL) -s -m 755 viewfax $(BINDIR)
++ $(INSTALL) -m 755 viewfax $(BINDIR)
+ $(INSTALL) -m 644 viewfax.man $(MANDIR)/viewfax.1
+ $(INSTALL) -m 644 viewfax.tif $(LIBDIR)
+
+--- a/g3/Makefile
++++ b/g3/Makefile
+@@ -37,13 +37,13 @@
+ # install programs
+ #
+ for f in $(G3_PROGRAMS) ; do \
+- $(INSTALL) -s -m 755 $$f $(BINDIR) ; \
++ $(INSTALL) -m 755 $$f $(BINDIR) ; \
+ done
+ #
+ # make symlink for "g3topbm" (so third-party fax viewers won't fail)
+-#
+- -cd $(BINDIR) ; \
+- test -x g3topbm || ln -s g32pbm g3topbm
++# Note for Gentoo: following lines will create collision with netpbm if netpbm is installed after
++# -cd $(BINDIR) ; \
++# test -x g3topbm || ln -s g32pbm g3topbm
+
+
+ # test suite
+--- a/Makefile
++++ b/Makefile
+@@ -596,12 +596,8 @@
+ $(INSTALL) -m 755 newslock $(BINDIR)
+
+ -test -d $(SBINDIR) || ( ./mkidirs $(SBINDIR) ; chmod 755 $(SBINDIR) )
+- if [ -f $(SBINDIR)/mgetty ] ; then \
+- mv -f $(SBINDIR)/mgetty $(SBINDIR)/mgetty.old ; fi
+- if [ -f $(SBINDIR)/sendfax ] ; then \
+- mv -f $(SBINDIR)/sendfax $(SBINDIR)/sendfax.old ; fi
+- $(INSTALL) -s -m 700 mgetty $(SBINDIR)
+- $(INSTALL) -s -m 755 sendfax $(SBINDIR)
++ $(INSTALL) -m 700 mgetty $(SBINDIR)
++ $(INSTALL) -m 755 sendfax $(SBINDIR)
+ #
+ # data files + directories
+ #
+@@ -663,7 +661,7 @@
+ if [ ! -z "$(INSTALL_MECHO)" ] ; then \
+ cd compat ; \
+ $(CC) $(CFLAGS) -o mg.echo mg.echo.c && \
+- $(INSTALL) -s -m 755 mg.echo $(BINDIR) ; \
++ $(INSTALL) -m 755 mg.echo $(BINDIR) ; \
+ fi
+
+ #
+--- a/mgetty.cfg.in
++++ b/mgetty.cfg.in
+@@ -20,16 +20,16 @@
+ # access the modem(s) with @SPEED@ bps
+ speed @SPEED@
+
+-# use these options to make the /dev/tty-device owned by "uucp.uucp"
++# use these options to make the /dev/tty-device owned by "fax.fax"
+ # and mode "rw-rw-r--" (0664). *LEADING ZERO NEEDED!*
+-#port-owner uucp
+-#port-group uucp
++#port-owner fax
++#port-group fax
+ #port-mode 0664
+
+-# use these options to make incoming faxes owned by "root.uucp"
++# use these options to make incoming faxes owned by "root.fax"
+ # and mode "rw-r-----" (0640). *LEADING ZERO NEEDED!*
+ #fax-owner root
+-#fax-group uucp
++#fax-group fax
+ #fax-mode 0640
+
+
+--- a/voice/Makefile
++++ b/voice/Makefile
+@@ -85,6 +85,7 @@
+ @echo ""
+ $(INSTALL) -m 700 vgetty/vgetty $(SBINDIR)
+ $(INSTALL) -m 755 vm/vm $(BINDIR)
++ $(INSTALL) -m 644 voice.conf-dist $(CONFDIR)/voice.conf
+ for i in $(PVFTOOLS); \
+ do \
+ $(INSTALL) -m 755 pvftools/$$i $(BINDIR); \
+--- a/voice/voice.conf-dist
++++ b/voice/voice.conf-dist
+@@ -47,11 +47,11 @@
+ voice_dir /var/spool/voice
+
+ #
+-# incoming messages are owned by "root.phone" and mode "rw-rw----" (0660)
++# incoming messages are owned by "fax:fax" and mode "rw-rw----" (0660)
+ #
+
+-phone_owner root
+-phone_group phone
++phone_owner fax
++phone_group fax
+ phone_mode 0660
+
+ #
diff --git a/net-dialup/mgetty/mgetty-1.2.1.ebuild b/net-dialup/mgetty/mgetty-1.2.1.ebuild
new file mode 100644
index 000000000000..a62a5460aee2
--- /dev/null
+++ b/net-dialup/mgetty/mgetty-1.2.1.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="fax and voice modem programs"
+HOMEPAGE="http://mgetty.greenie.net/"
+SRC_URI="ftp://mgetty.greenie.net/pub/mgetty/source/1.2/${P}.tar.gz"
+
+DEPEND="
+ doc? ( virtual/latex-base virtual/texi2dvi )
+ >=sys-apps/sed-4
+ sys-apps/groff
+ dev-lang/perl
+ sys-apps/texinfo
+ virtual/awk
+ fax? (
+ !net-misc/efax
+ !net-misc/hylafax
+ )
+"
+RDEPEND="${DEPEND}
+ fax? ( media-libs/netpbm app-text/ghostscript-gpl )
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc +fax fidonet"
+
+pkg_setup() {
+ enewgroup fax
+ enewuser fax -1 -1 /dev/null fax
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.36-callback.patch
+ "${FILESDIR}"/${PN}-1.1.36-tmpfile.patch
+ "${FILESDIR}"/${PN}-1.1.37-qa-fixes.patch
+ "${FILESDIR}"/${PN}-1.2.1-Lucent.c.patch
+ "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ chmod +x mkidirs
+
+ # don't install fax related files - bug #195467
+ use fax || eapply "${FILESDIR}/${PN}-1.1.37-nofax.patch"
+
+ sed -i -e 's:/usr/local/lib/mgetty+sendfax:/etc/mgetty+sendfax:' faxrunq.config || die 'changing mgetty config dir failed'
+ sed -i -e 's:/usr/local/bin/g3cat:/usr/bin/g3cat:' faxrunq.config fax/faxspool.rules || die 'changing g3cat path failed'
+
+ sed -e "/^doc-all:/s/mgetty.asc mgetty.info mgetty.dvi mgetty.ps/mgetty.info/" \
+ -i doc/Makefile || die 'first sed on doc/Makefile failed'
+ if use doc; then
+ sed -i \
+ -e "s/^doc-all:/doc-all: mgetty.ps/" \
+ -e "s/^all:/all: doc-all/" \
+ doc/Makefile || die 'second sed on doc/Makefile failed'
+ fi
+
+ sed -i \
+ -e 's:^CC=:CC?=:g' \
+ -e 's:^CFLAGS=:CFLAGS?=:g' \
+ {,*/}Makefile || die
+ sed -i \
+ -e 's:^AR=:AR?=:g' \
+ -e 's:^CFLAGS=:CFLAGS+= -I..:g' \
+ -e 's:^RANLIB=:RANLIB?=:g' \
+ */Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ sed -e 's:var/log/mgetty:var/log/mgetty/mgetty:' \
+ -e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
+ -e 's:\/\* \(\#define CNDFILE "dialin.config"\) \*\/:\1:' \
+ -e 's:\(\#define FAX_NOTIFY_PROGRAM\).*:\1 "/etc/mgetty+sendfax/new_fax":' \
+ policy.h-dist > policy.h || die 'creating policy.h failed'
+
+ sed -i \
+ -e "s/\$(CFLAGS) -o newslock/${CFLAGS} ${LDFLAGS} -Wall -o newslock/" \
+ -e "s/\$(LDLAGS)/${LDFLAGS}/" \
+ {,fax/}Makefile || die
+}
+
+src_compile() {
+ use fidonet && append-cppflags "-DFIDO"
+ append-cppflags "-DAUTO_PPP"
+ # bug #299421
+ VARTEXFONTS="${T}"/fonts emake -j1 prefix=/usr \
+ CONFDIR=/etc/mgetty+sendfax \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ all vgetty
+}
+
+src_install () {
+ # parallelization issue: vgetty-install target fails if install target
+ # isn't finished
+ local targets
+ for targets in install "vgetty-install install-callback"; do
+ emake prefix="${D}/usr" \
+ INFODIR="${D}/usr/share/info" \
+ CONFDIR="${D}/etc/mgetty+sendfax" \
+ MAN1DIR="${D}/usr/share/man/man1" \
+ MAN4DIR="${D}/usr/share/man/man4" \
+ MAN5DIR="${D}/usr/share/man/man5" \
+ MAN8DIR="${D}/usr/share/man/man8" \
+ SBINDIR="${D}/usr/sbin" \
+ BINDIR="${D}/usr/bin" \
+ VOICE_DIR="${D}/var/spool/voice" \
+ PHONE_GROUP=fax \
+ PHONE_PERMS=755 \
+ spool="${D}/var/spool" \
+ ${targets}
+ done
+
+ keepdir /var/log/mgetty
+
+ #Install mgetty into /sbin (#119078)
+ dodir /sbin && \
+ mv "${D}"/usr/sbin/mgetty "${D}"/sbin && \
+ dosym /sbin/mgetty /usr/sbin/mgetty || die "failed to install /sbin/mgetty"
+ #Don't install ct (#106337)
+ rm "${D}"/usr/bin/ct || die "failed to remove useless ct program"
+
+ dodoc BUGS ChangeLog README.1st Recommend THANKS TODO \
+ doc/*.txt doc/modems.db
+ doinfo doc/mgetty.info
+
+ docinto vgetty
+ dodoc voice/{Readme,Announce,ChangeLog,Credits}
+
+ if use doc; then
+ dodoc doc/mgetty.ps
+ fi
+
+ docinto vgetty/doc
+ dodoc voice/doc/*
+
+ if use fax; then
+ mv samples/new_fax.all samples_new_fax.all || die "move failed."
+ docinto samples
+ dodoc samples/*
+
+ docinto samples/new_fax
+ dodoc samples_new_fax.all/*
+ fi
+
+ if ! use fax; then
+ insinto /usr/share/${PN}/frontends
+ doins -r frontends/{voice,network}
+ else
+ insinto /usr/share/${PN}
+ doins -r frontends
+ fi
+ insinto /usr/share/${PN}
+ doins -r patches
+ insinto /usr/share/${PN}/voice
+ doins -r voice/{contrib,Perl,scripts}
+
+ diropts -m 0750 -o fax -g fax
+ dodir /var/spool/voice
+ keepdir /var/spool/voice/incoming
+ keepdir /var/spool/voice/messages
+ if use fax; then
+ dodir /var/spool/fax
+ dodir /var/spool/fax/outgoing
+ keepdir /var/spool/fax/outgoing/locks
+ keepdir /var/spool/fax/incoming
+ fi
+}
+
+pkg_postinst() {
+ elog "Users who wish to use the fax or voicemail capabilities must be members"
+ elog "of the group fax in order to access files"
+ elog
+ elog "If you want to grab voice messages from a remote location, you must save"
+ elog "the password in /var/spool/voice/.code file"
+}