summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Alex <tee@itc-gmbh.de>2018-03-08 05:15:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-10 23:55:18 +0100
commitf383f9a830166cd15646efd188a70a8929ec57e2 (patch)
tree3fc6f222ea8fc6bb6e03ecbe03d1eb8bcaf5f4d3 /net-dialup/xl2tpd
parentapp-vim/uptime: use HTTPS. (diff)
downloadgentoo-f383f9a830166cd15646efd188a70a8929ec57e2.tar.gz
gentoo-f383f9a830166cd15646efd188a70a8929ec57e2.tar.bz2
gentoo-f383f9a830166cd15646efd188a70a8929ec57e2.zip
net-dialup/xl2tpd: version bump to 1.3.11.
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7390
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/Manifest1
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.11.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/Manifest b/net-dialup/xl2tpd/Manifest
index cdc236b25afa..16cbb31b21a6 100644
--- a/net-dialup/xl2tpd/Manifest
+++ b/net-dialup/xl2tpd/Manifest
@@ -1,4 +1,5 @@
DIST xl2tpd-1.3.1.tar.gz 551923 BLAKE2B 2e0429167c73f0afab1bb79e0b81e0500ff8c4b1c32318fc7ec64f16bbffbf4099b8fba4efc172ccccad3e9cfbba1ad5eb4fb6a3a8243da592465bb07409c93d SHA512 2265a19eda1521fd4314ad1b28cc1bb781d2f0edb06ad619afbb364f5896e23db7e444ac10709c1ae9b9ac648e4354aea7af57bb5bc20b706b00e2a131fc29d6
DIST xl2tpd-1.3.10.tar.gz 510777 BLAKE2B 15ec09a6186d20facd4eceeca87a33a4676644a6976c2b69a61b288a2534c354bcc9b64eca4305aa7774d3b5fc29c97078478bebec7e81f8071865b29a97809e SHA512 304b8cd098608a866d32c65c55ba98a01e10abb473d8bff488c723fd1f6d4a66cf98c6d3044f7986a334739693767608c48999f873e95a51f0fa6c23cb61ecd4
+DIST xl2tpd-1.3.11.tar.gz 510652 BLAKE2B c120ba0a2bb96a87334743319808e4a1dfb1b95140fc37df51c33e176bdefdac547ad27d38731bab9d94a939b9a3ca93404ef17c8076e16567a3ecc5b568fb47 SHA512 9fd478aa6b7e22867aa977aa0c22ba9d856e3b659aa0ffdcdb17aa0d8358cceab37da565eeb799590d65fc2914720715423e006f6bbe7ca742f09d7cced52cb7
DIST xl2tpd-1.3.6.tar.gz 553981 BLAKE2B 3e79534fe3eaa906cf09da93b7f6be2931e4c7fc8ff43dd9683ae846e1e2351c3bee81ac8853dee6c7e45ad8b60f8727edbd95d6dd30cc508288227b09da351c SHA512 868c65660e6a45fb8dc22b95542e9d6ca0dc8e5033cc9df04171a651ef273bc5d711a85f61d4a971d714089f7a10ee67460d8ab9f3c007fcffe0e11e81ae0bfd
DIST xl2tpd-1.3.9.tar.gz 510538 BLAKE2B cf0ee309f13ab4024b97b1ca6fec2ec412b8084524b3bc6c108ba464c0b11b2483c4a166cf3f9afe8d6d64cd6db49b6cd6275ba204c4d8f2401d6fa58a7301de SHA512 858e342e3f5b9c460c8fd041cb2873c79dbb9fbef1e5caf8c367a6c74ca175c2a020a4b152757892c24950eebf701324c0ba682eafd23cd370d36da7118cb3d9
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.11.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.11.ebuild
new file mode 100644
index 000000000000..0c4c41e9011e
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="dnsretry"
+
+DEPEND="
+ net-libs/libpcap
+ >sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+ ${DEPEND}
+ net-dialup/ppp"
+
+DOCS=(CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents)
+
+src_prepare() {
+ default
+ # The below patch is questionable. Why wasn't it submitted upstream? If it
+ # ever breaks, it will just be removed. -darkside 20120914
+ # Patch has been discussed with upstream and is marked as feature by now:
+ # https://github.com/xelerance/xl2tpd/issues/134 // -- tenX 2017-08-06
+ use dnsretry && eapply -p0 "${FILESDIR}/${PN}-dnsretry.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake OSFLAGS="-DLINUX"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ newins doc/l2tp-secrets.sample l2tp-secrets
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
+
+ einstalldocs
+}