summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-08-17 10:45:27 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-08-17 10:47:23 +0300
commit341934bc73764ea6424917e3c6032e49ec3a2aee (patch)
tree7a7838c6be6acf0055e8fb71553c1b5812780ed2 /net-dialup
parentdev-libs/libmaxminddb: Old. (diff)
downloadgentoo-341934bc73764ea6424917e3c6032e49ec3a2aee.tar.gz
gentoo-341934bc73764ea6424917e3c6032e49ec3a2aee.tar.bz2
gentoo-341934bc73764ea6424917e3c6032e49ec3a2aee.zip
net-dialup/pptpd: revision bump
Bump to EAPI 6, create pidfile in /run instead of /var/run Took package maintainership Package-Manager: portage-2.2.28
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/pptpd/files/pptpd-1.4.0-pidfile.patch33
-rw-r--r--net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch4
-rw-r--r--net-dialup/pptpd/metadata.xml5
-rw-r--r--net-dialup/pptpd/pptpd-1.4.0-r2.ebuild80
4 files changed, 119 insertions, 3 deletions
diff --git a/net-dialup/pptpd/files/pptpd-1.4.0-pidfile.patch b/net-dialup/pptpd/files/pptpd-1.4.0-pidfile.patch
new file mode 100644
index 000000000000..59bc4a43ecd9
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.4.0-pidfile.patch
@@ -0,0 +1,33 @@
+--- a/pptpd.c 2016-08-16 15:35:51.660000000 +0300
++++ b/pptpd.c 2016-08-16 15:36:01.010000000 +0300
+@@ -115,7 +115,7 @@
+ printf(" (default is /etc/ppp/options).\n");
+ #endif
+ printf(" [-p] [--pidfile file] Specifies the file to write the process ID to\n");
+- printf(" (default is /var/run/pptpd.pid).\n");
++ printf(" (default is /run/pptpd.pid).\n");
+ #if !defined(BSDUSER_PPP)
+ printf(" [-s] [--speed baud] Specifies the baud speed for the PPP daemon\n");
+ printf(" (default is 115200).\n");
+--- a/pptpd.8 2016-08-16 15:34:53.480000000 +0300
++++ b/pptpd.8 2016-08-16 15:35:11.650000000 +0300
+@@ -72,7 +72,7 @@
+ .TP
+ \fB-p\fR|\fB--pidfile \fIpid-file
+ specifies an alternate location to store the process ID file (default
+-.IR /var/run/pptpd.pid ).
++.IR /run/pptpd.pid ).
+
+ .TP
+ \fB-s\fR|\fB--speed \fIbaud
+--- a/defaults.h 2016-08-16 15:35:01.050000000 +0300
++++ b/defaults.h 2016-08-16 15:35:20.190000000 +0300
+@@ -43,7 +43,7 @@
+ #else
+ #define PPTPD_CONFIG_FILE_DEFAULT "/etc/pptpd.conf"
+ #endif
+-#define PIDFILE_DEFAULT "/var/run/pptpd.pid"
++#define PIDFILE_DEFAULT "/run/pptpd.pid"
+
+ #define STIMEOUT_DEFAULT 10 /* seconds */
+
diff --git a/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch b/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch
index de91753f33f5..2162509d7d48 100644
--- a/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch
+++ b/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch
@@ -1,5 +1,5 @@
---- plugins/Makefile.orig 2013-05-15 14:36:33.994231829 +0400
-+++ plugins/Makefile 2013-05-15 14:37:06.686234429 +0400
+--- a/plugins/Makefile 2013-05-15 14:36:33.994231829 +0400
++++ b/plugins/Makefile 2013-05-15 14:37:06.686234429 +0400
@@ -17,14 +17,14 @@
%.so: %.c
$(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
diff --git a/net-dialup/pptpd/metadata.xml b/net-dialup/pptpd/metadata.xml
index d597e85e26cf..32a22c503fb9 100644
--- a/net-dialup/pptpd/metadata.xml
+++ b/net-dialup/pptpd/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
<use>
<flag name="gre-extreme-debug">Log all GRE accepted packages when in debug
mode (required if you want upstream support)</flag>
diff --git a/net-dialup/pptpd/pptpd-1.4.0-r2.ebuild b/net-dialup/pptpd/pptpd-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..c76de755f7f8
--- /dev/null
+++ b/net-dialup/pptpd/pptpd-1.4.0-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
+HOMEPAGE="http://poptop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gre-extreme-debug tcpd"
+
+DEPEND="net-dialup/ppp:=
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-sandbox-fix.patch"
+ "${FILESDIR}/${P}-pidfile.patch"
+)
+
+src_prepare() {
+ # Match pptpd-logwtmp.so's version with pppd's version (#89895)
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ sed -i -e "s:\\(#define[ \\t]*VERSION[ \\t]*\\)\".*\":\\1\"${PPPD_VER}\":" plugins/patchlevel.h || die
+
+ # configure.in is actually configure.ac
+ mv configure.in configure.ac || die
+
+ # Automake 1.13 compatibility, bug #469476
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADER/' configure.ac || die 'sed on configure.ac failed'
+
+ # remove 'missing' script to prevent warnings
+ rm missing || die 'remove missing script failed'
+
+ # respect compiler, bug #461722
+ tc-export CC
+
+ # Call to default src_prepare to apply patches
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ use gre-extreme-debug && append-cppflags "-DLOG_DEBUG_GRE_ACCEPTING_PACKET"
+ econf \
+ --enable-bcrelay \
+ $(use tcpd && echo "--with-libwrap")
+}
+
+src_compile() {
+ emake COPTS="${CFLAGS}"
+}
+
+src_install () {
+ default
+
+ insinto /etc
+ doins samples/pptpd.conf
+
+ insinto /etc/ppp
+ doins samples/options.pptpd
+
+ newinitd "${FILESDIR}/pptpd-init-r2" pptpd
+ newconfd "${FILESDIR}/pptpd-confd" pptpd
+
+ dodoc README.*
+ dodoc -r samples
+}