summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /net-dialup
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/mgetty/mgetty-1.2.1.ebuild2
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild2
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-dialup/mgetty/mgetty-1.2.1.ebuild b/net-dialup/mgetty/mgetty-1.2.1.ebuild
index 3f2e2683eddd..0bf35cf88fda 100644
--- a/net-dialup/mgetty/mgetty-1.2.1.ebuild
+++ b/net-dialup/mgetty/mgetty-1.2.1.ebuild
@@ -120,7 +120,7 @@ src_install () {
#Install mgetty into /sbin (#119078)
dodir /sbin && \
mv "${D}"/usr/sbin/mgetty "${D}"/sbin && \
- dosym /sbin/mgetty /usr/sbin/mgetty || die "failed to install /sbin/mgetty"
+ dosym /sbin/mgetty /usr/sbin/mgetty
#Don't install ct (#106337)
rm "${D}"/usr/bin/ct || die "failed to remove useless ct program"
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild
index 4ac3355af7cb..ec86e01bd7fb 100644
--- a/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild
@@ -73,7 +73,7 @@ src_compile() {
emake
if use tk; then
- emake -C "${S}/gui" || die "gui make failed"
+ emake -C "${S}/gui"
fi
}
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild
index 5a62bbd85690..2f775fca64a2 100644
--- a/net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild
@@ -75,7 +75,7 @@ src_compile() {
emake
if use tk; then
- emake -C "${S}/gui" || die "gui make failed"
+ emake -C "${S}/gui"
fi
}