summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Alex <tee@itc-gmbh.de>2017-08-21 05:57:42 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-29 11:46:06 +0200
commit3aa0b0db30345c833e99cfe7cd976a4c0bbd97da (patch)
tree979d696e6cb7fcc476c675ed383745770893a5e7 /net-dialup
parentapp-admin/filebeat: drop old. (diff)
downloadgentoo-3aa0b0db30345c833e99cfe7cd976a4c0bbd97da.tar.gz
gentoo-3aa0b0db30345c833e99cfe7cd976a4c0bbd97da.tar.bz2
gentoo-3aa0b0db30345c833e99cfe7cd976a4c0bbd97da.zip
net-dialup/xl2tpd: version bump to 1.3.10.
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5490
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/Manifest1
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.10.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/Manifest b/net-dialup/xl2tpd/Manifest
index 996b37595fe7..bed6c8ef9022 100644
--- a/net-dialup/xl2tpd/Manifest
+++ b/net-dialup/xl2tpd/Manifest
@@ -1,3 +1,4 @@
DIST xl2tpd-1.3.1.tar.gz 551923 SHA256 147ea96a957628bc31bba6fd5f5ef5522366691f936ce4c0a0988d9876e3ba14 SHA512 2265a19eda1521fd4314ad1b28cc1bb781d2f0edb06ad619afbb364f5896e23db7e444ac10709c1ae9b9ac648e4354aea7af57bb5bc20b706b00e2a131fc29d6 WHIRLPOOL b5465605ae5c3bbf73227f11958a43c66191bb557447ce224de044358e738331cf8e64e783bb5527517683cbcc59d57df9cc17c990f652fe7aed1ab2cfd7f9b2
+DIST xl2tpd-1.3.10.tar.gz 510777 SHA256 48bbc86b448a51bf167f1e04d10e2b97f9e928da42eb0dd455b419ef0522d1c3 SHA512 304b8cd098608a866d32c65c55ba98a01e10abb473d8bff488c723fd1f6d4a66cf98c6d3044f7986a334739693767608c48999f873e95a51f0fa6c23cb61ecd4 WHIRLPOOL a1912740ebf1aeae3e2133443b92bbe28db91937701796ee8136009522ca1e7416d6a406182a820fee0c68904fb6f07556e618749613f96c7e8b2ae240a1d669
DIST xl2tpd-1.3.6.tar.gz 553981 SHA256 49b069aa8d873e1d8f615ccc4212351e427bf681ba453fdd211256a8345bb7fb SHA512 868c65660e6a45fb8dc22b95542e9d6ca0dc8e5033cc9df04171a651ef273bc5d711a85f61d4a971d714089f7a10ee67460d8ab9f3c007fcffe0e11e81ae0bfd WHIRLPOOL 92bf661e0ae95bcf80cb8b8c5c9c8648d3aa5375a9dc598f0f4fa3be3bce2bc9a36a60eabf44da3dad24fb3f2b03e30b960d73e6a16c51c8ea25397639766328
DIST xl2tpd-1.3.9.tar.gz 510538 SHA256 62f683ab4cda2941261e37828f2939b5a2e85b437e9a3cd86bbd660c26e04a1e SHA512 858e342e3f5b9c460c8fd041cb2873c79dbb9fbef1e5caf8c367a6c74ca175c2a020a4b152757892c24950eebf701324c0ba682eafd23cd370d36da7118cb3d9 WHIRLPOOL 186ed1f8729eacbf6aa35ac0af97fdf1124ff85cebd119ba0d7f6d303fbfa3292fb7c247c3308743fd2785de0ebaa8fd7adf7801b6f4db8102abf9211f84732a
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.10.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.10.ebuild
new file mode 100644
index 000000000000..32fb054177dc
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="dnsretry"
+
+DEPEND="
+ net-libs/libpcap
+ >sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+ ${DEPEND}
+ net-dialup/ppp"
+
+DOCS=(CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents)
+
+src_prepare() {
+ default
+ # The below patch is questionable. Why wasn't it submitted upstream? If it
+ # ever breaks, it will just be removed. -darkside 20120914
+ # Patch has been discussed with upstream and is marked as feature by now:
+ # https://github.com/xelerance/xl2tpd/issues/134 // -- tenX 2017-08-06
+ use dnsretry && eapply -p0 "${FILESDIR}/${PN}-dnsretry.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake OSFLAGS="-DLINUX"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ newins doc/l2tp-secrets.sample l2tp-secrets
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
+
+ einstalldocs
+}