summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-07-28 14:58:43 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-07-28 15:06:08 +0300
commitb647c383f528693999a2774a5d7f7726f57e2605 (patch)
treefc49c9a50b7f804174abcc74be279fd8aeb12023 /net-dialup
parentmedia-video/pipewire: Stabilize 0.3.75-r2 ppc, #911332 (diff)
downloadgentoo-b647c383f528693999a2774a5d7f7726f57e2605.tar.gz
gentoo-b647c383f528693999a2774a5d7f7726f57e2605.tar.bz2
gentoo-b647c383f528693999a2774a5d7f7726f57e2605.zip
net-dialup/lrzsz: fix gettext 0.22
Fix compilation with gettext 0.22. Update EAPI 7 -> 8. Closes: https://bugs.gentoo.org/908861 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/lrzsz/files/lrzsz-0.12.20-gettext-0.22.patch48
-rw-r--r--net-dialup/lrzsz/lrzsz-0.12.20-r6.ebuild67
2 files changed, 115 insertions, 0 deletions
diff --git a/net-dialup/lrzsz/files/lrzsz-0.12.20-gettext-0.22.patch b/net-dialup/lrzsz/files/lrzsz-0.12.20-gettext-0.22.patch
new file mode 100644
index 000000000000..016e6dd40262
--- /dev/null
+++ b/net-dialup/lrzsz/files/lrzsz-0.12.20-gettext-0.22.patch
@@ -0,0 +1,48 @@
+gettext 0.22 removed BUILD_INCLUDED_LIBINTL and USE_INCLUDED_LIBINTL is 'no'
+
+INSTOBJEXT was deprecated and removed, replace with .mo
+
+Bug: https://bugs.gentoo.org/908861
+
+--- a/intl/Makefile.in
++++ b/intl/Makefile.in
+@@ -81,7 +81,7 @@
+
+ INCLUDES = -I.. -I. -I$(top_srcdir)/intl -I$(top_srcdir)/lib
+
+-all: all-@USE_INCLUDED_LIBINTL@
++all: all-no
+
+ all-yes: libintl.$la intlh.inst
+ all-no:
+--- a/configure.in
++++ b/configure.in
+@@ -98,7 +98,7 @@
+ AM_PROG_AR
+ AC_ISC_POSIX
+ AC_USE_SYSTEM_EXTENSIONS
+-AM_GNU_GETTEXT
++AM_GNU_GETTEXT([use-libtool])
+ AC_C_CONST
+ AC_C_INLINE
+
+@@ -264,6 +264,8 @@
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(LIBS)
+
++INTLLIBS="$LIBINTL"
++AC_SUBST(INTLLIBS)
+
+ AC_DEFINE_UNQUOTED(LOCALEDIR,"$prefix/$DATADIRNAME", [LOCALEDIR])
+ AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
+--- a/po/Makefile.in.in
++++ b/po/Makefile.in.in
+@@ -53,7 +53,7 @@
+
+ CATALOGS = de.gmo
+ CATOBJEXT = @CATOBJEXT@
+-INSTOBJEXT = @INSTOBJEXT@
++INSTOBJEXT = .mo
+
+ .SUFFIXES:
+ .SUFFIXES: .c .o .po .pox .gmo .mo .msg .cat
diff --git a/net-dialup/lrzsz/lrzsz-0.12.20-r6.ebuild b/net-dialup/lrzsz/lrzsz-0.12.20-r6.ebuild
new file mode 100644
index 000000000000..08671484501a
--- /dev/null
+++ b/net-dialup/lrzsz/lrzsz-0.12.20-r6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Communication package providing the X, Y, and ZMODEM file transfer protocols"
+HOMEPAGE="https://www.ohse.de/uwe/software/lrzsz.html"
+SRC_URI="https://www.ohse.de/uwe/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DEPEND="nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-autotools.patch
+ "${FILESDIR}"/${PN}-implicit-decl.patch
+ "${FILESDIR}"/${P}-automake-1.12.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-gettext-0.20.patch
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
+ "${FILESDIR}"/${P}-gettext-0.22.patch
+)
+
+DOCS=( AUTHORS COMPATABILITY ChangeLog NEWS \
+ README{,.cvs,.gettext,.isdn4linux,.tests} THANKS TODO )
+
+src_prepare() {
+ default
+
+ # automake is unhappy if this is missing
+ >> config.rpath || die
+ # This is too old. Remove it so automake puts in a newer copy.
+ rm missing || die
+ # Autoheader does not like seeing this file.
+ rm acconfig.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf $(use_enable nls)
+}
+
+src_test() {
+ # Don't use check target.
+ # See bug #120748 before changing this function.
+ emake vcheck
+}
+
+src_install() {
+ default
+
+ local x
+ for x in {r,s}{b,x,z} ; do
+ dosym l${x} /usr/bin/${x}
+ dosym l${x:0:1}z.1 /usr/share/man/man1/${x}.1
+ [ "${x:1:1}" = "z" ] || dosym l${x:0:1}z.1 /usr/share/man/man1/l${x}.1
+ done
+}