summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-08-19 19:34:27 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-08-20 09:24:05 +0300
commitb71db11c9c7b4b0d79de03f603f4398f3cf2f3a3 (patch)
treea654a4799a0a2e1388e55bf0a815b13d3214a210 /net-dialup
parentdev-perl/Mail-Message: Stabilize 3.13.0 x86, #912507 (diff)
downloadgentoo-b71db11c9c7b4b0d79de03f603f4398f3cf2f3a3.tar.gz
gentoo-b71db11c9c7b4b0d79de03f603f4398f3cf2f3a3.tar.bz2
gentoo-b71db11c9c7b4b0d79de03f603f4398f3cf2f3a3.zip
net-dialup/lrzsz: fix installation without gettext
If gettext is not installed, eautoreconf breaks the package. Embed required m4 files to fix this. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/lrzsz/Manifest1
-rw-r--r--net-dialup/lrzsz/files/lrzsz-0.12.20-disable-nls.patch25
-rw-r--r--net-dialup/lrzsz/lrzsz-0.12.20-r7.ebuild74
3 files changed, 100 insertions, 0 deletions
diff --git a/net-dialup/lrzsz/Manifest b/net-dialup/lrzsz/Manifest
index 77293a9cd1d0..7e386a9ee3bb 100644
--- a/net-dialup/lrzsz/Manifest
+++ b/net-dialup/lrzsz/Manifest
@@ -1 +1,2 @@
DIST lrzsz-0.12.20.tar.gz 280938 BLAKE2B 86511ab112da849f5894f18c045f2c8a9dd4c4e97426c1d98c5b91aade6c39e26f4a7e5674e057c9596a240dfd3ef32053fcdc8ee58b33654cf15eec64779b1e SHA512 9bce64036f1f1c65f5910f19802aecaf3dc5ffeab0feeca10fa8d2fe1b83e212391cce23056d22fd0eda52df89e12ede68eb5d22ffcf22f935910d2af7399f12
+DIST lrzsz-m4-0.12.20.tar.bz2 23959 BLAKE2B 933e43f80a40478baef77d69f81fcb04947f2d0afb87f777b0c000ea4223408bf3e55d687cf625ab4835fb30e274f7058ff09ee3b51ad90e09723cd3053ee038 SHA512 c8818381f2e5271bc2dd7d469c0a33a6b22d42d3159b41f168223473a8b03322f3ff91a49ce398e3ef5abe7b355d92b83b1429d0c6d450d19985a60e2e1190d4
diff --git a/net-dialup/lrzsz/files/lrzsz-0.12.20-disable-nls.patch b/net-dialup/lrzsz/files/lrzsz-0.12.20-disable-nls.patch
new file mode 100644
index 000000000000..b0f290e71564
--- /dev/null
+++ b/net-dialup/lrzsz/files/lrzsz-0.12.20-disable-nls.patch
@@ -0,0 +1,25 @@
+This package does not contain the m4 macros from gettext, so if gettext is not
+installed the macros are lost when running eautoreconf.
+
+Embed the required m4 files and add the directory to configure.ac.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,6 +5,7 @@
+ noinst_SCRIPTS=systype
+ PR=@PACKAGE@-@VERSION@
+ CLEAN_FILES=fastcheck.done
++AC_CONFIG_MACRO_DIR=-I m4
+
+ dist-hook:
+ mkdir $(distdir)/debian
+--- a/configure.in
++++ b/configure.in
+@@ -3,6 +3,7 @@
+ AC_INIT(src/crctab.c)
+ AM_INIT_AUTOMAKE(lrzsz, 0.12.20)
+ AC_CONFIG_HEADERS([config.h])
++AC_CONFIG_MACRO_DIR([m4])
+
+
+ dnl AC_C_CROSS is in AC_PROG_CC since 2.12
diff --git a/net-dialup/lrzsz/lrzsz-0.12.20-r7.ebuild b/net-dialup/lrzsz/lrzsz-0.12.20-r7.ebuild
new file mode 100644
index 000000000000..252debc21c72
--- /dev/null
+++ b/net-dialup/lrzsz/lrzsz-0.12.20-r7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Communication package providing the X, Y, and ZMODEM file transfer protocols"
+HOMEPAGE="https://www.ohse.de/uwe/software/lrzsz.html"
+SRC_URI="
+ https://www.ohse.de/uwe/releases/${P}.tar.gz
+ https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${PN}-m4-${PV}.tar.bz2
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DEPEND="nls? ( virtual/libintl )"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-autotools.patch
+ "${FILESDIR}"/${PN}-implicit-decl.patch
+ "${FILESDIR}"/${P}-automake-1.12.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-gettext-0.20.patch
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
+ "${FILESDIR}"/${P}-gettext-0.22.patch
+ "${FILESDIR}"/${P}-disable-nls.patch
+)
+
+DOCS=( AUTHORS COMPATABILITY ChangeLog NEWS \
+ README{,.cvs,.gettext,.isdn4linux,.tests} THANKS TODO )
+
+src_prepare() {
+ default
+
+ # automake is unhappy if this is missing
+ >> config.rpath || die
+ # This is too old. Remove it so automake puts in a newer copy.
+ rm missing || die
+ # Autoheader does not like seeing this file.
+ rm acconfig.h || die
+ # embed default m4 files in case gettext is not installed
+ mv "${WORKDIR}"/m4 . || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf $(use_enable nls)
+}
+
+src_test() {
+ # Don't use check target.
+ # See bug #120748 before changing this function.
+ emake vcheck
+}
+
+src_install() {
+ default
+
+ local x
+ for x in {r,s}{b,x,z} ; do
+ dosym l${x} /usr/bin/${x}
+ dosym l${x:0:1}z.1 /usr/share/man/man1/${x}.1
+ [ "${x:1:1}" = "z" ] || dosym l${x:0:1}z.1 /usr/share/man/man1/l${x}.1
+ done
+}