summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 15:03:22 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commitd7eac327a4a996893146f36d52f7ed3463ab6d31 (patch)
tree285cbcb22323a284d31c8058b38bd09230355d97 /net-dialup
parentnet-dialup/capi4k-utils: remove capi4k-utils-20050718-r6 (diff)
downloadgentoo-d7eac327a4a996893146f36d52f7ed3463ab6d31.tar.gz
gentoo-d7eac327a4a996893146f36d52f7ed3463ab6d31.tar.bz2
gentoo-d7eac327a4a996893146f36d52f7ed3463ab6d31.zip
inet-dialup/capifwd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Also update to EAPI=6 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capifwd/capifwd-0.6.3-r2.ebuild42
-rw-r--r--net-dialup/capifwd/files/capifwd.init4
2 files changed, 43 insertions, 3 deletions
diff --git a/net-dialup/capifwd/capifwd-0.6.3-r2.ebuild b/net-dialup/capifwd/capifwd-0.6.3-r2.ebuild
new file mode 100644
index 000000000000..621c0616a15e
--- /dev/null
+++ b/net-dialup/capifwd/capifwd-0.6.3-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A daemon forwarding CAPI messages to capi20proxy clients"
+HOMEPAGE="http://capi20proxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/capi20proxy/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/linux-server"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}.patch"
+ eapply -p0 "${FILESDIR}/${P}-amd64.patch"
+
+ # Replace obsolete sys_errlist with strerror
+ sed -i -e 's:sys_errlist *\[ *errno *\]:strerror(errno):' \
+ src/capifwd.c src/capi/waitforsignal.c src/auth/auth.c || \
+ die "failed to replace sys_errlist"
+
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="$D" install
+ dodoc AUTHORS ChangeLog README
+
+ # install init-script
+ newinitd "${FILESDIR}/capifwd.init" capifwd
+ newconfd "${FILESDIR}/capifwd.conf" capifwd
+}
diff --git a/net-dialup/capifwd/files/capifwd.init b/net-dialup/capifwd/files/capifwd.init
index 0c339f35eecb..f49bc1ebd503 100644
--- a/net-dialup/capifwd/files/capifwd.init
+++ b/net-dialup/capifwd/files/capifwd.init
@@ -1,10 +1,8 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-opts="start stop"
-
depend() {
need capi
}