summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 16:12:06 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commite7136174409ecbaf4ad4ae2bf7d9a0f965ff645b (patch)
tree48fbf0925c4c36eee6805319f3b6c0b6aeb420ae /net-dialup
parentnet-dialup/cistronradius: remove cistronradius-1.6.8-r1 (diff)
downloadgentoo-e7136174409ecbaf4ad4ae2bf7d9a0f965ff645b.tar.gz
gentoo-e7136174409ecbaf4ad4ae2bf7d9a0f965ff645b.tar.bz2
gentoo-e7136174409ecbaf4ad4ae2bf7d9a0f965ff645b.zip
net-dialup/diald: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/diald/diald-1.0-r3.ebuild59
-rw-r--r--net-dialup/diald/files/diald-init4
2 files changed, 61 insertions, 2 deletions
diff --git a/net-dialup/diald/diald-1.0-r3.ebuild b/net-dialup/diald/diald-1.0-r3.ebuild
new file mode 100644
index 000000000000..35134f12ab33
--- /dev/null
+++ b/net-dialup/diald/diald-1.0-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools pam
+
+DESCRIPTION="Daemon that provides on demand IP links via SLIP or PPP"
+HOMEPAGE="http://diald.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Old-MIT GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )
+ sys-apps/tcp-wrappers"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-posix.patch"
+ eapply "${FILESDIR}/${P}-gentoo.patch"
+ if ! use pam; then
+ eapply "${FILESDIR}/${P}-nopam.patch"
+ rm "${S}"/README.pam
+ cd "${S}"
+ eautoconf
+ fi
+ eapply_user
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ sysconfdir=/etc \
+ bindir=/usr/bin \
+ sbindir=/usr/sbin \
+ mandir=/usr/share/man \
+ libdir=/usr/lib/diald \
+ BINGRP=root \
+ ROOTUID=root \
+ ROOTGRP=root \
+ install || die "make failed"
+ use pam && pamd_mimic_system diald auth account
+
+ dodir /var/cache/diald
+ mknod -m 0660 "${D}/var/cache/diald/diald.ctl" p
+
+ dodoc BUGS CHANGES NOTES README* \
+ THANKS TODO TODO.budget doc/diald-faq.txt
+ docinto setup ; cp -pPR setup/* "${D}/usr/share/doc/${PF}/setup"
+ docinto contrib ; cp -pPR contrib/* "${D}/usr/share/doc/${PF}/contrib"
+
+ insinto /etc/diald ; doins "${FILESDIR}"/{diald.conf,diald.filter}
+ newinitd "${FILESDIR}/diald-init" diald
+}
diff --git a/net-dialup/diald/files/diald-init b/net-dialup/diald/files/diald-init
index 6eefde3d5797..e5bed84f0cc0 100644
--- a/net-dialup/diald/files/diald-init
+++ b/net-dialup/diald/files/diald-init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$