summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-03-23 20:26:07 -0400
committerAaron Bauman <bman@gentoo.org>2018-03-23 20:27:03 -0400
commitd008a9babbdd680601477d27b8f5ff14dcdbf70c (patch)
tree3a2379b2868d99e77fa17d9a9d800e8c68f9ec1d /net-dns/bind-tools
parentnet-dns/bind: drop vulnerable wrt bug #644706 (diff)
downloadgentoo-d008a9babbdd680601477d27b8f5ff14dcdbf70c.tar.gz
gentoo-d008a9babbdd680601477d27b8f5ff14dcdbf70c.tar.bz2
gentoo-d008a9babbdd680601477d27b8f5ff14dcdbf70c.zip
net-dns/bind-tools: drop vulnerable wrt bug #644706
Diffstat (limited to 'net-dns/bind-tools')
-rw-r--r--net-dns/bind-tools/Manifest1
-rw-r--r--net-dns/bind-tools/bind-tools-9.11.1_p3.ebuild136
2 files changed, 0 insertions, 137 deletions
diff --git a/net-dns/bind-tools/Manifest b/net-dns/bind-tools/Manifest
index bae4f022e515..7aa88f4a7f2f 100644
--- a/net-dns/bind-tools/Manifest
+++ b/net-dns/bind-tools/Manifest
@@ -1,2 +1 @@
-DIST bind-9.11.1-P3.tar.gz 9749095 BLAKE2B 1b68b57b9aed1a5210464e9c47a4e0569f1932076c042a7096dc04f69b45da9df8b2d56ec0f1f0d0fb136e7f61a39b3cb20d1912075f3a4138cbdf47f859cf0a SHA512 bf92ce1e07e5c84cc42b413bdbd3ad97f37712a6dc330dc10182992d948b7a393d5446efa188379b39020c34d810cebe2a7acccc9b8aa6bb564e1f3e6be42e96
DIST bind-9.11.2_p1.tar.gz 9783329 BLAKE2B 5a3bbd87112064231bd5e6b09ebb4014f9d5cf65cb601c03555ff540a22d87aec3990cd8e37ce5ff09e9a149bdf122d20ecb01f87731e6c79d80379a6926014f SHA512 168f27f580e3be2f7ada27afa2f72e715e750eec76831cf01bd32fabc1fa65dc29dab0eb7ed1682b076d3be99269897ddbc2c10551631a3911d9e5ae1aa40597
diff --git a/net-dns/bind-tools/bind-tools-9.11.1_p3.ebuild b/net-dns/bind-tools/bind-tools-9.11.1_p3.ebuild
deleted file mode 100644
index 58ee7e1ee3a8..000000000000
--- a/net-dns/bind-tools/bind-tools-9.11.1_p3.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils autotools flag-o-matic toolchain-funcs
-
-MY_PN=${PN//-tools}
-MY_PV=${PV/_p/-P}
-MY_PV=${MY_PV/_rc/rc}
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
-HOMEPAGE="http://www.isc.org/software/bind"
-SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~amd64-fbsd"
-IUSE="doc gost gssapi idn ipv6 libressl readline seccomp ssl urandom xml"
-# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
-
-REQUIRED_USE="gost? ( !libressl ssl )"
-
-CDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
- gost? ( >=dev-libs/openssl-1.0.0:0=[-bindist] )
- xml? ( dev-libs/libxml2 )
- idn? ( <net-dns/idnkit-2:= )
- gssapi? ( virtual/krb5 )
- readline? ( sys-libs/readline:0= )
- seccomp? ( sys-libs/libseccomp )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- !<net-dns/bind-9.10.2"
-
-S="${WORKDIR}/${MY_P}"
-
-# bug 479092, requires networking
-RESTRICT="test"
-
-src_prepare() {
- # bug 600212
- epatch "${FILESDIR}"/${PN}-9.11.0_p5-dyndb-dlopen.patch
-
- epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch #231247
-
- # Disable tests for now, bug 406399
- sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
-
- # bug #220361
- rm aclocal.m4
- rm -rf libtool.m4/
-
- mv configure.in configure.ac || die # configure.in is deprecated
- eautoreconf
-}
-
-src_configure() {
- local myconf=
-
- if use urandom; then
- myconf="${myconf} --with-randomdev=/dev/urandom"
- else
- myconf="${myconf} --with-randomdev=/dev/random"
- fi
-
- # bug 344029
- append-cflags "-DDIG_SIGCHASE"
-
- # localstatedir for nsupdate -l, bug 395785
- tc-export BUILD_CC
- econf \
- --localstatedir=/var \
- --without-python \
- --without-libjson \
- --without-zlib \
- --without-lmdb \
- --disable-openssl-version-check \
- $(use_enable ipv6) \
- $(use_with idn) \
- $(usex idn --with-idnlib=-lidnkit '') \
- $(use_enable seccomp) \
- $(use_with ssl openssl) \
- $(use_with xml libxml2) \
- $(use_with gssapi) \
- $(use_with readline) \
- $(use_with gost) \
- ${myconf}
-
- # bug #151839
- echo '#undef SO_BSDCOMPAT' >> config.h
-}
-
-src_compile() {
- local AR=$(tc-getAR)
-
- emake AR="${AR}" -C lib/
- emake AR="${AR}" -C bin/delv/
- emake AR="${AR}" -C bin/dig/
- emake AR="${AR}" -C bin/nsupdate/
- emake AR="${AR}" -C bin/dnssec/
-}
-
-src_install() {
- dodoc README CHANGES FAQ
-
- cd "${S}"/bin/delv
- dobin delv
- doman delv.1
-
- cd "${S}"/bin/dig
- dobin dig host nslookup
- doman {dig,host,nslookup}.1
-
- cd "${S}"/bin/nsupdate
- dobin nsupdate
- doman nsupdate.1
- if use doc; then
- dohtml nsupdate.html
- fi
-
- cd "${S}"/bin/dnssec
- for tool in dsfromkey importkey keyfromlabel keygen \
- revoke settime signzone verify; do
- dobin dnssec-"${tool}"
- doman dnssec-"${tool}".8
- if use doc; then
- dohtml dnssec-"${tool}".html
- fi
- done
-}