summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-10-14 03:28:40 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-10-14 03:28:58 -0400
commit4713589132fe11ec3184fb2602492139ce66ab37 (patch)
tree6fc0d9da2368f2491b9a3cd433d18fababca50b1 /net-dns/c-ares/c-ares-1.12.0.ebuild
parentdev-java/commons-lang: version bump - 3.4 (diff)
downloadgentoo-4713589132fe11ec3184fb2602492139ce66ab37.tar.gz
gentoo-4713589132fe11ec3184fb2602492139ce66ab37.tar.bz2
gentoo-4713589132fe11ec3184fb2602492139ce66ab37.zip
net-dns/c-ares: version bump to 1.12.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-dns/c-ares/c-ares-1.12.0.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.12.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.12.0.ebuild b/net-dns/c-ares/c-ares-1.12.0.ebuild
new file mode 100644
index 000000000000..4741b2f4886b
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="http://c-ares.haxx.se/"
+SRC_URI="http://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="static-libs"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-remove-tests.patch
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}