summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-10-28 05:35:40 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-10-28 05:35:40 -0400
commit8cab555cc56b98645febf7583c0375b4e736f099 (patch)
tree15ffe36a62e14e7a2ac134a0ba60cbdb923f2be8 /net-dns/c-ares
parentnet-print/cups-filters: Fix /run path and poppler subslot dep (diff)
downloadgentoo-8cab555cc56b98645febf7583c0375b4e736f099.tar.gz
gentoo-8cab555cc56b98645febf7583c0375b4e736f099.tar.bz2
gentoo-8cab555cc56b98645febf7583c0375b4e736f099.zip
net-dns/c-ares: version bump to 1.18.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-dns/c-ares')
-rw-r--r--net-dns/c-ares/Manifest1
-rw-r--r--net-dns/c-ares/c-ares-1.18.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index 38e443759abf..5cde624b8679 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -1 +1,2 @@
DIST c-ares-1.17.2.tar.gz 1538276 BLAKE2B c6f5ad65ca75f8467b624daf3caaee2f35d6e4714ce46ebe1bbf79447feecf8615915b00fa5e7bd1e97c6232864e06c53a792fbadf36a5399883529769273e24 SHA512 f625e0ef8508af6475d3e83b51ab29be8a4878e2a87e7f518bea046b76a74bfde7043ca6ec2a9e714c898ab9e5d4a5a678c3347a9f9eb68980438f7ca8ae3fc8
+DIST c-ares-1.18.1.tar.gz 1560165 BLAKE2B c03a572726c6bbb24a3e4773673d0c87f4833bb9582aed57a424eea8c965beb6e232f502b61922b124d37403d91ebfefe0db7373673fc22e0d752c4e5036eb07 SHA512 1276ec0799916019f8c0af6b55a139701bd15e0ca4a00811d07963893978bc96c107b980f0fd49f81aa70bc8b3b8cd671195ba357c390772d4c2c5643c50c5a5
diff --git a/net-dns/c-ares/c-ares-1.18.1.ebuild b/net-dns/c-ares/c-ares-1.18.1.ebuild
new file mode 100644
index 000000000000..25030c0afdae
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.18.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+multilib_src_configure() {
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ ax_cv_uts_namespace=no \
+ ax_cv_user_namespace=no \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}")) || die "arestest failed!"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}