summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-17 02:37:37 +0100
committerSam James <sam@gentoo.org>2021-08-17 02:41:14 +0100
commited3440a766d1d06282db32de0273e53ac7d74da9 (patch)
treeed3cab49575426d527aa2505d138864912a6e717 /net-dns/c-ares
parentsys-cluster/kube-scheduler: stabilize 1.19.13 on amd64 (diff)
downloadgentoo-ed3440a766d1d06282db32de0273e53ac7d74da9.tar.gz
gentoo-ed3440a766d1d06282db32de0273e53ac7d74da9.tar.bz2
gentoo-ed3440a766d1d06282db32de0273e53ac7d74da9.zip
net-dns/c-ares: skip network tests
Closes: https://bugs.gentoo.org/807649 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/c-ares')
-rw-r--r--net-dns/c-ares/c-ares-1.17.2.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-dns/c-ares/c-ares-1.17.2.ebuild b/net-dns/c-ares/c-ares-1.17.2.ebuild
index 8a95c494c5ef..dd99e46267ec 100644
--- a/net-dns/c-ares/c-ares-1.17.2.ebuild
+++ b/net-dns/c-ares/c-ares-1.17.2.ebuild
@@ -40,7 +40,19 @@ multilib_src_test() {
# We're skipping the "real" network tests with the filter
# see https://github.com/c-ares/c-ares/tree/main/test
- ./arestest --gtest_filter=-*Live* || die "arestest failed!"
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}")) || die "arestest failed!"
}
multilib_src_install_all() {