summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmily Mills <emily@emlove.me>2020-09-23 14:56:30 -0400
committerConrad Kostecki <conikost@gentoo.org>2020-09-23 22:19:15 +0200
commited73f41c299d750f7f07bad56014a3f1d138950c (patch)
tree16ce4986a4134232f1d56ba335dcbda122a8e5c9 /net-dns/ddclient
parentsys-auth/sssd: fix samba, change to man USE, add autoconf dep (diff)
downloadgentoo-ed73f41c299d750f7f07bad56014a3f1d138950c.tar.gz
gentoo-ed73f41c299d750f7f07bad56014a3f1d138950c.tar.bz2
gentoo-ed73f41c299d750f7f07bad56014a3f1d138950c.zip
net-dns/ddclient: Process tmpfiles after install
Previously, the ddclient cache directory was not created until a reboot. Switching to the new tmpfiles eclass lets us process the tmpfile config after installing to ensure the service can be started immediately. Closes: https://github.com/gentoo/gentoo/pull/17647 Signed-off-by: Emily Mills <emily@emlove.me> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/ddclient-3.9.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-dns/ddclient/ddclient-3.9.1.ebuild b/net-dns/ddclient/ddclient-3.9.1.ebuild
index cd30dfa85f2f..8cdf7b8d9a91 100644
--- a/net-dns/ddclient/ddclient-3.9.1.ebuild
+++ b/net-dns/ddclient/ddclient-3.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Perl client used to update dynamic DNS entries"
HOMEPAGE="https://ddclient.net/"
@@ -51,7 +51,7 @@ src_install() {
newinitd "${FILESDIR}"/ddclient.initd-r6 ddclient
systemd_newunit "${FILESDIR}"/ddclient.service-r1 ddclient.service
- systemd_newtmpfilesd "${FILESDIR}"/ddclient.tmpfiles ddclient.conf
+ newtmpfiles "${FILESDIR}"/ddclient.tmpfiles ddclient.conf
dodoc Change* README* RELEASENOTE TODO UPGRADE
@@ -60,3 +60,7 @@ src_install() {
dodoc sample-*
fi
}
+
+pkg_postinst() {
+ tmpfiles_process ddclient.conf
+}