summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-02 08:12:12 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-02 17:43:58 -0500
commit0a4405074f435983fb6515a2cfed1dca2a67a783 (patch)
treed2d757d57580cd72b2c3e689a64d974a9b1013dc /net-dns/djbdns
parentmedia-libs/mesa: Require glslang if USE=vulkan (diff)
downloadgentoo-0a4405074f435983fb6515a2cfed1dca2a67a783.tar.gz
gentoo-0a4405074f435983fb6515a2cfed1dca2a67a783.tar.bz2
gentoo-0a4405074f435983fb6515a2cfed1dca2a67a783.zip
net-dns/djbdns: new revision increasing tinydns's softlimit.
The tinydns launch script imposes a "softlimit" on the amount of memory it can use, and sometime recently (in djbdns terms, anyway), the old default of 300000 became insufficient. We raise it 4500000. This will only help new installations; users with existing ones will need to modify their local launch scripts because the script itself is not controlled by the package manager. Thanks to Vadim Efimov for pointing out that this problem is widespread and in need of fixing. Closes: https://bugs.gentoo.org/883159 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/djbdns-1.05-r38.ebuild (renamed from net-dns/djbdns/djbdns-1.05-r37.ebuild)1
-rw-r--r--net-dns/djbdns/files/tinydns-softlimit.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/net-dns/djbdns/djbdns-1.05-r37.ebuild b/net-dns/djbdns/djbdns-1.05-r38.ebuild
index 95606086af30..b9e8644c4128 100644
--- a/net-dns/djbdns/djbdns-1.05-r37.ebuild
+++ b/net-dns/djbdns/djbdns-1.05-r38.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/CVE2009-0858_0001-check-response-domain-name-length.patch"
"${FILESDIR}/CVE2012-1191_0001-ghost-domain-attack.patch"
"${FILESDIR}/AR-and-RANLIB-support.patch"
+ "${FILESDIR}/tinydns-softlimit.patch"
)
src_prepare() {
diff --git a/net-dns/djbdns/files/tinydns-softlimit.patch b/net-dns/djbdns/files/tinydns-softlimit.patch
new file mode 100644
index 000000000000..89d80d933012
--- /dev/null
+++ b/net-dns/djbdns/files/tinydns-softlimit.patch
@@ -0,0 +1,18 @@
+Use a larger memory limit by default than was chosen at the beginning
+of time. This is evidently necessary on many machines, including my
+own, starting somewhere around December 2020.
+
+https://bugs.gentoo.org/883159
+
+diff -Naur a/tinydns-conf.c b/tinydns-conf.c
+--- a/tinydns-conf.c 2001-02-11 21:11:45.000000000 +0000
++++ b/tinydns-conf.c 2021-11-08 17:23:06.181385437 +0000
+@@ -46,7 +46,7 @@
+
+ start("run");
+ outs("#!/bin/sh\nexec 2>&1\nexec envuidgid "); outs(user);
+- outs(" envdir ./env softlimit -d300000 ");
++ outs(" envdir ./env softlimit -d4500000 ");
+ outs(auto_home); outs("/bin/tinydns\n");
+ finish();
+ perm(0755);