summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-04-11 23:53:25 -0700
committerMichał Górny <mgorny@gentoo.org>2018-04-20 09:27:32 +0200
commit0481c755b3192bf2f9e40c9ca83128b3f97b55b8 (patch)
treeb9cbe05fffcb123b168144e9540d62dfcbe656b5 /net-dns/dnscrypt-proxy
parentnet-misc/youtube-viewer: Remove old versions up till latest stable (diff)
downloadgentoo-0481c755b3192bf2f9e40c9ca83128b3f97b55b8.tar.gz
gentoo-0481c755b3192bf2f9e40c9ca83128b3f97b55b8.tar.bz2
gentoo-0481c755b3192bf2f9e40c9ca83128b3f97b55b8.zip
net-dns/dnscrypt-proxy: version bump to 2.0.10
Use upstream provided systemd unit. It unit now offers additional hardening: DynamicUsers and private directories. ebuild no longer owns log directory, service manages will create it on startup automatically. Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'net-dns/dnscrypt-proxy')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.10.ebuild98
-rw-r--r--net-dns/dnscrypt-proxy/files/config-full-paths-r10.patch72
3 files changed, 171 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index bd117a443454..17a4d7219ef5 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1,3 @@
DIST dnscrypt-proxy-1.9.5.tar.bz2 1290573 BLAKE2B 8f16fdb58012e00a8b58d36364377c3bc25158b9484a8df2bd6bc98d1c9cbf5ac758997e31f95ecaeb9da2f6b7272316c5a4a1c069a39549fbc1c1b136857da0 SHA512 84c0f7587521b3a198292cf20dd71cb592ccf8a9e003abbc62c5ca112f6c5ed27c49b1642cf91f403d52b4147e25f24af540b65cecfcf93814338329097df836
+DIST dnscrypt-proxy-2.0.10.tar.gz 2773118 BLAKE2B 331b62c84cf84f26757dd5e663d5ea8fa59b90a2b149cac5e795b6f7edad810b7dcd0fa2e6e9ce77d6d19d9d708a9ed7d30a7e8d43986545c6f38c3e623e3681 SHA512 b28bbce986bace9c4ee1acfe5b372b9f847d5a0a199b085ead31813ad697753b6a25cead72a90a1967bd473bb4bcb591a384765b2de9af817af0dde3d33dcb58
DIST dnscrypt-proxy-2.0.8.tar.gz 750606 BLAKE2B 83a9201389061c250e0c6bf535ff2e718aa9f67202887dcad33847160325225ccc1197b98343a8012bc84f5f42f049131b01b78febd7a418d47db946c9f58779 SHA512 c7e7d5d72fa6874b2b6b4deaaf6c80e4a2e812670b71bf7a308535a5773e84e249263bbb66d18fb844d8e440703facb0902f3872b117433582696695cb5a7265
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.10.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.10.ebuild
new file mode 100644
index 000000000000..948f785d3d5f
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.10.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd user
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="systemd"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+pkg_setup() {
+ enewgroup dnscrypt
+ enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_prepare() {
+ default
+ # Create directory structure suitable for building
+ mkdir -p "src/${EGO_PN%/*}" || die
+ mv "${PN}" "src/${EGO_PN}" || die
+ mv "vendor" "src/" || die
+
+ if use systemd; then
+ sed -i 's|\['\''127\.0\.0\.1:53'\'', '\''\[::1\]:53'\''\]|\[\]|' \
+ "src/${EGO_PN}"/example-dnscrypt-proxy.toml || die
+ fi
+}
+
+src_install() {
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+ doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ insinto "/usr/share/dnscrypt-proxy"
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd-r2 dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd-r2 dnscrypt-proxy
+ systemd_dounit systemd/dnscrypt-proxy.service
+ systemd_dounit systemd/dnscrypt-proxy.socket
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53 if started via OpenRC"
+ ewarn "please either change port to > 1024, configure to run ${PN} as root"
+ ewarn "or re-enable 'filecaps'"
+ ewarn
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v} == 1.* ]] ; then
+ elog "Version 2.x.x is a complete rewrite of ${PN}"
+ elog "please clean up old config/log files"
+ elog
+ fi
+ done
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Starting with version 2.0.9 ${PN} unit changed:"
+ elog "It now runs as an unprivileged user with dynamic UID/GID"
+ elog "and privately stores log and cache files"
+ elog
+ elog "See man:systemd.exec, man:nss-systemd"
+ elog
+ elog "Edit ${PN}.socket if you need to change port and address"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}
diff --git a/net-dns/dnscrypt-proxy/files/config-full-paths-r10.patch b/net-dns/dnscrypt-proxy/files/config-full-paths-r10.patch
new file mode 100644
index 000000000000..aba278c221a2
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/files/config-full-paths-r10.patch
@@ -0,0 +1,72 @@
+--- dnscrypt-proxy-2.0.9/dnscrypt-proxy/example-dnscrypt-proxy.toml 2018-04-11 05:05:16.000000000 -0700
++++ dnscrypt-proxy-2.0.9/dnscrypt-proxy/dnscrypt-proxy.toml 2018-04-11 22:29:21.810501858 -0700
+@@ -96,7 +96,7 @@
+
+ ## log file for the application
+
+-# log_file = 'dnscrypt-proxy.log'
++# log_file = '/var/log/dnscrypt-proxy/dnscrypt-proxy.log'
+
+
+ ## Use the system logger (syslog on Unix, Event Log on Windows)
+@@ -254,7 +254,7 @@
+
+ ## Path to the query log file (absolute, or relative to the same directory as the executable file)
+
+- # file = 'query.log'
++ # file = '/var/log/dnscrypt-proxy/query.log'
+
+
+ ## Query log format (currently supported: tsv and ltsv)
+@@ -280,7 +280,7 @@
+
+ ## Path to the query log file (absolute, or relative to the same directory as the executable file)
+
+- # file = 'nx.log'
++ # file = '/var/log/dnscrypt-proxy/nx.log'
+
+
+ ## Query log format (currently supported: tsv and ltsv)
+@@ -315,7 +315,7 @@
+
+ ## Optional path to a file logging blocked queries
+
+- # log_file = 'blocked.log'
++ # log_file = '/var/log/dnscrypt-proxy/blocked.log'
+
+
+ ## Optional log format: tsv or ltsv (default: tsv)
+@@ -343,7 +343,7 @@
+
+ ## Optional path to a file logging blocked queries
+
+- # log_file = 'ip-blocked.log'
++ # log_file = '/var/log/dnscrypt-proxy/ip-blocked.log'
+
+
+ ## Optional log format: tsv or ltsv (default: tsv)
+@@ -371,7 +371,7 @@
+
+ ## Optional path to a file logging whitelisted queries
+
+- # log_file = 'whitelisted.log'
++ # log_file = '/var/log/dnscrypt-proxy/whitelisted.log'
+
+
+ ## Optional log format: tsv or ltsv (default: tsv)
+@@ -441,7 +441,7 @@
+
+ [sources.'public-resolvers']
+ urls = ['https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v2/public-resolvers.md', 'https://download.dnscrypt.info/resolvers-list/v2/public-resolvers.md']
+- cache_file = 'public-resolvers.md'
++ cache_file = '/var/cache/dnscrypt-proxy/public-resolvers.md'
+ minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
+ refresh_delay = 72
+ prefix = ''
+@@ -451,7 +451,7 @@
+
+ # [sources.'parental-control']
+ # urls = ['https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v2/parental-control.md', 'https://download.dnscrypt.info/resolvers-list/v2/parental-control.md']
+- # cache_file = 'parental-control.md'
++ # cache_file = '/var/cache/dnscrypt-proxy/parental-control.md'
+ # minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'