summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-03-22 05:53:10 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-04-03 22:17:36 +0200
commit7ce007911465e67aac63e193ceafed3af9045e5c (patch)
treeb42953c2976bbc29ffee90222d02142c4f5c1f37 /net-dns/dnsviz
parentsys-boot/syslinux: Add binutils-2.32 compatibility patch, bug 662678 (diff)
downloadgentoo-7ce007911465e67aac63e193ceafed3af9045e5c.tar.gz
gentoo-7ce007911465e67aac63e193ceafed3af9045e5c.tar.bz2
gentoo-7ce007911465e67aac63e193ceafed3af9045e5c.zip
net-dns/dnsviz: new package.
DNSViz is a tool suite for analysis and visualization of Domain Name System (DNS) behavior, including its security extensions (DNSSEC). Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11454 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-dns/dnsviz')
-rw-r--r--net-dns/dnsviz/Manifest1
-rw-r--r--net-dns/dnsviz/dnsviz-0.8.2.ebuild47
-rw-r--r--net-dns/dnsviz/metadata.xml20
3 files changed, 68 insertions, 0 deletions
diff --git a/net-dns/dnsviz/Manifest b/net-dns/dnsviz/Manifest
new file mode 100644
index 000000000000..7f11cfca787b
--- /dev/null
+++ b/net-dns/dnsviz/Manifest
@@ -0,0 +1 @@
+DIST dnsviz-0.8.2.tar.gz 404265 BLAKE2B c4ba6b5a7d6fee7c8e2cba0c90f29560152dd4beed1ef4d80a6a3bf9f81646ee8f0d61c38329233e300f2b434cb5d9e9d2a926dc72997ae68ff0a57e147bafcf SHA512 5414d9bda6c0bf5fdc5a84a09cb5833619110702749b12f87d63f5149de473f4bd1b6960c506c60ec5fc5ff82d789536cee70a299ff13c960a45776de2916c80
diff --git a/net-dns/dnsviz/dnsviz-0.8.2.ebuild b/net-dns/dnsviz/dnsviz-0.8.2.ebuild
new file mode 100644
index 000000000000..74b6aa78b4b8
--- /dev/null
+++ b/net-dns/dnsviz/dnsviz-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
+HOMEPAGE="http://dnsviz.net/"
+SRC_URI="https://github.com/dnsviz/dnsviz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/libnacl[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.31.0[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ ${DEPEND}"
+
+python_prepare_all() {
+ # Fix the ebuild to use correct FHS/Gentoo policy paths for 0.8.2
+ sed -i "s*share/doc/dnsviz*share/doc/dnsviz-${PV}*g" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Support for extra feature can be get from:"
+ optfeature "Support for pre-deployment testing" net-dns/bind
+
+ # Warn about extra requirements for >=OpenSSL 1.1.0
+ if has_version '=dev-libs/openssl-1.1*'; then
+ echo
+ ewarn "With OpenSSL version 1.1.0 and later,the OpenSSL GOST Engine"
+ ewarn "is necessary to validate DNSSEC signatures with algorithm 12"
+ ewarn "(GOST R 34.10-2001) and digests of type 3 (GOST R 34.11-94)"
+ ewarn "OpenSSL GOST Engine can be get from --> dev-libs/gost-engine"
+ fi
+}
diff --git a/net-dns/dnsviz/metadata.xml b/net-dns/dnsviz/metadata.xml
new file mode 100644
index 000000000000..c1ee72309eb6
--- /dev/null
+++ b/net-dns/dnsviz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hasan.calisir@psauxit.com</email>
+ <name>Hasan ÇALIŞIR</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ DNSViz is a tool suite for analysis and visualization of Domain Name
+ System (DNS) behavior, including its security extensions (DNSSEC).
+ This tool suite powers the Web-based analysis.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dnsviz/dnsviz</remote-id>
+ </upstream>
+</pkgmetadata>