summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-01-22 00:56:44 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-01-22 00:56:44 +0100
commitc54be7954002bc9c61a973a1884b2d13e6062161 (patch)
tree74f70f47f394712676489e84a3edc3fb6c9c91ae /net-dns/dnsviz
parentnet-libs/zeromq: update HOMEPAGE (diff)
downloadgentoo-c54be7954002bc9c61a973a1884b2d13e6062161.tar.gz
gentoo-c54be7954002bc9c61a973a1884b2d13e6062161.tar.bz2
gentoo-c54be7954002bc9c61a973a1884b2d13e6062161.zip
net-dns/dnsviz: bump to v0.9.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-dns/dnsviz')
-rw-r--r--net-dns/dnsviz/Manifest1
-rw-r--r--net-dns/dnsviz/dnsviz-0.9.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-dns/dnsviz/Manifest b/net-dns/dnsviz/Manifest
index 7f11cfca787b..b0e1ecd70cd7 100644
--- a/net-dns/dnsviz/Manifest
+++ b/net-dns/dnsviz/Manifest
@@ -1 +1,2 @@
DIST dnsviz-0.8.2.tar.gz 404265 BLAKE2B c4ba6b5a7d6fee7c8e2cba0c90f29560152dd4beed1ef4d80a6a3bf9f81646ee8f0d61c38329233e300f2b434cb5d9e9d2a926dc72997ae68ff0a57e147bafcf SHA512 5414d9bda6c0bf5fdc5a84a09cb5833619110702749b12f87d63f5149de473f4bd1b6960c506c60ec5fc5ff82d789536cee70a299ff13c960a45776de2916c80
+DIST dnsviz-0.9.1.tar.gz 477806 BLAKE2B 24fc4c34a763cf4ea6018f42bb4ab12c376ff1a5ff29e4bc4502600c997195d5c83fd0b4d18c72fddc0d669380d3a39930d7bd6d3970671becd64a5c3083d269 SHA512 006377676173c225eb3a18d09d0808ab35412d09e988b984fd67598c8a6917a4fefd9381c32ea4dda404d7dde8d51e7b36dc49d85a8b4c2a8928fbde89075adf
diff --git a/net-dns/dnsviz/dnsviz-0.9.1.ebuild b/net-dns/dnsviz/dnsviz-0.9.1.ebuild
new file mode 100644
index 000000000000..a390da1b6999
--- /dev/null
+++ b/net-dns/dnsviz/dnsviz-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
+HOMEPAGE="https://dnsviz.net/"
+SRC_URI="https://github.com/dnsviz/dnsviz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/dnspython-1.13[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.37.0[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ ${DEPEND}"
+
+python_prepare_all() {
+ # Fix the ebuild to use correct FHS/Gentoo policy paths
+ sed -i \
+ -e "s|share/doc/dnsviz|share/doc/${PF}|g" \
+ "${S}"/setup.py \
+ || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ "${EPYTHON}" tests/offline_tests.py -v || die
+
+ # No need to pull in net-dns/bind for this small test
+ if hash named-checkconf &>/dev/null ; then
+ "${EPYTHON}" tests/local_probe_tests.py -v || die
+ else
+ einfo "Skipping local_probe_tests -- named-checkconf not found!"
+ fi
+}
+
+pkg_postinst() {
+ elog "Support for extra feature can be get from:"
+ optfeature "Support for pre-deployment testing" net-dns/bind
+ optfeature "Support for DNSSEC signatures using GOST algorithm or digest" dev-libs/ghost-engine
+}