summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/fpdns
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/fpdns')
-rw-r--r--net-dns/fpdns/Manifest1
-rw-r--r--net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch33
-rw-r--r--net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild34
-rw-r--r--net-dns/fpdns/metadata.xml31
4 files changed, 99 insertions, 0 deletions
diff --git a/net-dns/fpdns/Manifest b/net-dns/fpdns/Manifest
new file mode 100644
index 000000000000..42b7c3383258
--- /dev/null
+++ b/net-dns/fpdns/Manifest
@@ -0,0 +1 @@
+DIST fpdns-0.10.0_pre20130404.tar.gz 931723 SHA256 fe81de9c5d2d077cd974c9fd862f52a02cc1bb29c58944ea968a21853cc8ea15 SHA512 1a4d9c1cb666efa3f48dcca2b5cd04793e92727359652095572b17479f5343479c57d2937f1fff8070c071a2698eda5c4dff981caf86436f184f0b076b0fa0b3 WHIRLPOOL 09b0588fdba51313787b17e1093a91d948aff1a203880943b3e16cf3c8c2a9296b679f13de24862b75d9f8e3c17b0598b12066932f3c07c2c47d793b84b30827
diff --git a/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch b/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch
new file mode 100644
index 000000000000..17eadbe4a139
--- /dev/null
+++ b/net-dns/fpdns/files/fpdns-0.10.0_pre20130404.ro-header.patch
@@ -0,0 +1,33 @@
+From ca0391377ad7150e61ff300cb5195c97a154233b Mon Sep 17 00:00:00 2001
+From: Jakob Schlyter <jakob@kirei.se>
+Date: Wed, 28 Aug 2013 10:24:11 +0200
+Subject: [PATCH] do not set header counters unless changed
+
+---
+ lib/Net/DNS/Fingerprint.pm | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/lib/Net/DNS/Fingerprint.pm b/lib/Net/DNS/Fingerprint.pm
+index d4a2e5a..e096d42 100644
+--- a/lib/Net/DNS/Fingerprint.pm
++++ b/lib/Net/DNS/Fingerprint.pm
+@@ -2171,10 +2171,12 @@ sub fp2header {
+ $header->ad(shift @list);
+ $header->cd(shift @list);
+ $header->rcode(shift @list);
+- $header->qdcount(shift @list);
+- $header->ancount(shift @list);
+- $header->nscount(shift @list);
+- $header->arcount(shift @list);
++
++ my ($qdcount, $ancount, $nscount, $arcount) = @list;
++ $header->qdcount($qdcount) unless $qdcount == $header->qdcount;
++ $header->qdcount($ancount) unless $ancount == $header->ancount;
++ $header->qdcount($nscount) unless $nscount == $header->nscount;
++ $header->qdcount($arcount) unless $arcount == $header->arcount;
+ }
+
+ sub probe {
+--
+1.9.1
+
diff --git a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
new file mode 100644
index 000000000000..08b4fa0c439d
--- /dev/null
+++ b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module
+
+DESCRIPTION="Fingerprinting DNS servers"
+HOMEPAGE="https://github.com/kirei/fpdns/"
+
+MY_P="${PN}-${PV##*_pre}"
+SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-perl/Net-DNS-0.74"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ ## fixes https://github.com/kirei/fpdns/issues/6
+ epatch "${FILESDIR}/${P}.ro-header.patch"
+}
+
+src_install() {
+ newbin apps/fpdns fpdns
+ insinto "${VENDOR_LIB}"/Net/DNS/
+ doins lib/Net/DNS/Fingerprint.pm
+}
diff --git a/net-dns/fpdns/metadata.xml b/net-dns/fpdns/metadata.xml
new file mode 100644
index 000000000000..dab638cf573a
--- /dev/null
+++ b/net-dns/fpdns/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+A nameserver basically responds to a query. Interoperability is an obvious
+requirement here. The standard protocol behaviour of different DNS
+implementations is expected to be the same.
+
+Requirements for protocol behaviour of DNS implementations is widely documented
+in the case of 'common' dns messages. The DNS protocol is over 20 years old and
+since its inception, there have been over 40 independent DNS implementations,
+while some implementations have over 20 versions.
+
+The methodology used to identify individual nameserver implementations is based
+on "borderline" protocol behaviour. The DNS protocol offers a multitude of
+message bits, response types, opcodes, classes, query types and label types in a
+fashion that makes some mutually exclusive while some are not used in a query
+messages at all. Not every implementation offers the full set of features the
+DNS protocol set currently has. Some implementations offer features outside the
+protocol set, and there are implementations that do not conform to standards.
+
+Also, new features added to - or bugs removed allow for differentiations between
+versions of an implementation.
+</longdescription>
+ <upstream>
+ <remote-id type="github">kirei/fpdns</remote-id>
+ </upstream>
+</pkgmetadata>