summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-04 04:29:15 +0000
committerSam James <sam@gentoo.org>2023-01-04 04:32:01 +0000
commitcc25cdb9b5d8c035c062a0e9a3e31c1047c158a7 (patch)
tree049d13f83708ea0b9f755376e25578d9c1a284c0 /net-dns/getdns
parentapp-misc/gcal: fix configure w/ clang 16 (diff)
downloadgentoo-cc25cdb9b5d8c035c062a0e9a3e31c1047c158a7.tar.gz
gentoo-cc25cdb9b5d8c035c062a0e9a3e31c1047c158a7.tar.bz2
gentoo-cc25cdb9b5d8c035c062a0e9a3e31c1047c158a7.zip
net-dns/getdns: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/getdns')
-rw-r--r--net-dns/getdns/files/getdns-1.7.2-clang16.patch55
-rw-r--r--net-dns/getdns/getdns-1.7.2-r1.ebuild (renamed from net-dns/getdns/getdns-1.7.2.ebuild)3
2 files changed, 57 insertions, 1 deletions
diff --git a/net-dns/getdns/files/getdns-1.7.2-clang16.patch b/net-dns/getdns/files/getdns-1.7.2-clang16.patch
new file mode 100644
index 000000000000..4b6b58f285a0
--- /dev/null
+++ b/net-dns/getdns/files/getdns-1.7.2-clang16.patch
@@ -0,0 +1,55 @@
+https://github.com/getdnsapi/getdns/commit/9c076ca34b9569eb60861da9a99f895a49d5a7b4
+
+From 9c076ca34b9569eb60861da9a99f895a49d5a7b4 Mon Sep 17 00:00:00 2001
+From: Willem Toorop <willem@nlnetlabs.nl>
+Date: Mon, 22 Aug 2022 10:40:35 +0200
+Subject: [PATCH] Issue #526 Some gldns files need stdlib
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -262,6 +262,7 @@ check_include_file(inttypes.h HAVE_INTTYPES_H)
+ check_include_file(limits.h HAVE_LIMITS_H)
+ check_include_file(sys/limits.h HAVE_SYS_LIMITS_H)
+ check_include_file(stdarg.h HAVE_STDARG_H)
++check_include_file(stddef.h HAVE_STDDEF_H)
+ check_include_file(stdint.h HAVE_STDINT_H)
+ check_include_file(stdio.h HAVE_STDIO_H)
+ check_include_file(stdlib.h HAVE_STDLIB_H)
+--- a/cmake/include/cmakeconfig.h.in
++++ b/cmake/include/cmakeconfig.h.in
+@@ -15,6 +15,7 @@
+ #cmakedefine HAVE_LIMITS_H 1
+ #cmakedefine HAVE_SYS_LIMITS_H 1
+ #cmakedefine HAVE_STDARG_H 1
++#cmakedefine HAVE_STDDEF_H 1
+ #cmakedefine HAVE_STDINT_H 1
+ #cmakedefine HAVE_STDIO_H 1
+ #cmakedefine HAVE_STDLIB_H 1
+@@ -241,6 +242,10 @@
+ # define FD_SETSIZE 1024
+ # endif
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ /* the version of the windows API enabled */
+ # ifndef WINVER
+ # define WINVER 0x0600 // 0x0502
+@@ -307,12 +312,11 @@
+ #include <string.h>
+ #endif
+
+-#ifdef __cplusplus
+-extern "C" {
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
+ #endif
+
+-#if STDC_HEADERS
+-#include <stdlib.h>
++#ifdef HAVE_STDDEF_H
+ #include <stddef.h>
+ #endif
+
+
diff --git a/net-dns/getdns/getdns-1.7.2.ebuild b/net-dns/getdns/getdns-1.7.2-r1.ebuild
index 76268cdfdcd1..624b78286187 100644
--- a/net-dns/getdns/getdns-1.7.2.ebuild
+++ b/net-dns/getdns/getdns-1.7.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -53,6 +53,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.4.2-stubby.service.patch"
+ "${FILESDIR}/${P}-clang16.patch"
)
src_configure() {