summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 11:51:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commit8329cd8ff4422e2a46a0d2d5e621ae45a3e5400e (patch)
treeb1651f5d56f5b9a9bd2e6bf9d41797c53548d837 /net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
parentnet-im/err: Move to virtual/dnspython (diff)
downloadgentoo-8329cd8ff4422e2a46a0d2d5e621ae45a3e5400e.tar.gz
gentoo-8329cd8ff4422e2a46a0d2d5e621ae45a3e5400e.tar.bz2
gentoo-8329cd8ff4422e2a46a0d2d5e621ae45a3e5400e.zip
net-dns/hash-slinger: Move to virtual/dnspython
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild')
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
new file mode 100644
index 000000000000..8fb61bfb181d
--- /dev/null
+++ b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
+HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
+SRC_URI="https://people.redhat.com/pwouters/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipsec +openpgp +ssh"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/ipaddr[$PYTHON_USEDEP]
+ dev-python/m2crypto[$PYTHON_USEDEP]
+ net-dns/unbound[python,$PYTHON_USEDEP]
+ virtual/dnspython[$PYTHON_USEDEP]
+ ipsec? ( net-misc/libreswan[dnssec] )
+ openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
+ ssh? ( net-misc/openssh )
+"
+
+src_install() {
+ local tools
+ tools="tlsa"
+ use ssh && tools+=" sshfp"
+ use openpgp && tools+=" openpgpkey"
+ use ipsec && tools+=" ipseckey"
+ for tool in $tools ; do
+ doman ${tool}.1
+ python_foreach_impl python_doscript ${tool}
+ done
+ dodoc BUGS CHANGES README
+}