summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-02-13 12:05:09 -0400
committerMarc Schiffbauer <mschiff@gentoo.org>2020-02-13 12:05:34 -0400
commitc892eaaf1f4f13a26094e89f4492f8fad80cd6d5 (patch)
tree8109a5645b1e2421f7137c753478613fe7e6431a /net-dns/hash-slinger
parentdev-python/pmw: drop 2to3 call (diff)
downloadgentoo-c892eaaf1f4f13a26094e89f4492f8fad80cd6d5.tar.gz
gentoo-c892eaaf1f4f13a26094e89f4492f8fad80cd6d5.tar.bz2
gentoo-c892eaaf1f4f13a26094e89f4492f8fad80cd6d5.zip
net-dns/hash-slinger: re-add version 3.0 with fixed deps
Package-Manager: Portage-2.3.84, Repoman-2.3.16 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'net-dns/hash-slinger')
-rw-r--r--net-dns/hash-slinger/Manifest1
-rw-r--r--net-dns/hash-slinger/hash-slinger-3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-dns/hash-slinger/Manifest b/net-dns/hash-slinger/Manifest
index 4ed6fa60ca07..90fc8f89c889 100644
--- a/net-dns/hash-slinger/Manifest
+++ b/net-dns/hash-slinger/Manifest
@@ -1,2 +1,3 @@
DIST hash-slinger-2.6.tar.gz 34864 BLAKE2B 4bd66a30ce0f6f57676d8c8691a38743b2b4263fc600b9a3756f1ff4676477bd61a4b20df082227a3437ca2bcbb1ad4e44643f8a87cda0a1123dab8fafa26140 SHA512 1e5d67ed2ef8eae910927fbd7419928d87ba31a91ca43a1c163b05f725da96a50d30e1539c4c55a68a22f0e2c9a2f7c7101fbdcfb5fc903e87fe4c22e20f33af
DIST hash-slinger-2.7.tar.gz 37684 BLAKE2B e8758251c51139723778ca0db271cbc730e19bba25fad3f7f784f06774ce52038f520c11b526fffd30570854112f0e7b184f6d05e4d20847ac2c014bc66151f8 SHA512 b1b3e46c4cdd8b983b55156c9bcc58afc973c2503cde48283e98306e381753547f425bfaee68707ae10b2e31b71d01485b34e4a9841c9ce2048f9551f23d0976
+DIST hash-slinger-3.0.tar.gz 38056 BLAKE2B e72bbddf587225c86ccf7b5c76a48bdece2bf1925a496ae930e9a4973ae47992fea5ca6c0e9e594a1170c0bdbbb3c8712c492c870c8c2e8f523ce247e4e2a4a4 SHA512 7528f267669cdc0c18e1d00c27fff96d915b3143c5534a09c834df3e140035159feeeb8b177528e89cd25265560d0734ef1af94d2f9d28fef47d7ca391e84516
diff --git a/net-dns/hash-slinger/hash-slinger-3.0.ebuild b/net-dns/hash-slinger/hash-slinger-3.0.ebuild
new file mode 100644
index 000000000000..20e3aac4906a
--- /dev/null
+++ b/net-dns/hash-slinger/hash-slinger-3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Various tools to generate DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
+HOMEPAGE="https://github.com/letoams/hash-slinger"
+SRC_URI="https://people.redhat.com/pwouters/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/letoams/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ipsec +openpgp +ssh"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+ ')
+ net-dns/unbound[python,${PYTHON_SINGLE_USEDEP}]
+ ipsec? ( net-vpn/libreswan[dnssec] )
+ openpgp? ( $(python_gen_cond_dep 'dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}]') )
+ ssh? ( net-misc/openssh )
+"
+
+src_install() {
+ local tools tool
+ tools="tlsa"
+ use ssh && tools+=" sshfp"
+ use openpgp && tools+=" openpgpkey"
+ use ipsec && tools+=" ipseckey"
+ for tool in $tools ; do
+ doman ${tool}.1
+ python_doscript ${tool}
+ done
+ dodoc BUGS CHANGES README
+}