summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-20 06:52:56 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-20 06:52:56 +0100
commit2c52c62be78c0e454e5d74a5b7bc8a00f102c516 (patch)
treea2f802cebbfc78475dbbf31ca2c3a15ca0827e37 /net-dns/libidn2/libidn2-0.16.ebuild
parentnet-analyzer/arping: Old. (diff)
downloadgentoo-2c52c62be78c0e454e5d74a5b7bc8a00f102c516.tar.gz
gentoo-2c52c62be78c0e454e5d74a5b7bc8a00f102c516.tar.bz2
gentoo-2c52c62be78c0e454e5d74a5b7bc8a00f102c516.zip
net-dns/libidn2: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-dns/libidn2/libidn2-0.16.ebuild')
-rw-r--r--net-dns/libidn2/libidn2-0.16.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-dns/libidn2/libidn2-0.16.ebuild b/net-dns/libidn2/libidn2-0.16.ebuild
new file mode 100644
index 000000000000..1b90fbf6104a
--- /dev/null
+++ b/net-dns/libidn2/libidn2-0.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/jas/libidn2"
+SRC_URI="
+ mirror://gnu-alpha/libidn/${P}.tar.gz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ sys-apps/help2man
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12-Werror.patch
+ "${FILESDIR}"/${PN}-0.12-examples.patch
+ "${FILESDIR}"/${PN}-0.16-gengetopt.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+
+ prune_libtool_files
+}