summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-27 09:53:55 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-27 09:54:09 +0100
commitc12f1e51431a567d75aa70bd40fff76abfcfb8cb (patch)
treecee372057dfdebcb8199c25d4debd5939c24b1ba /net-dns/libidn
parentdev-ruby/hoe: stable 3.16.0 for hppa, bug #634930 (diff)
downloadgentoo-c12f1e51431a567d75aa70bd40fff76abfcfb8cb.tar.gz
gentoo-c12f1e51431a567d75aa70bd40fff76abfcfb8cb.tar.bz2
gentoo-c12f1e51431a567d75aa70bd40fff76abfcfb8cb.zip
net-dns/libidn: Prevent autotools updates (bug #638952 by skobk.in).
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-dns/libidn')
-rw-r--r--net-dns/libidn/files/libidn-1.33-parallel-make.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/net-dns/libidn/files/libidn-1.33-parallel-make.patch b/net-dns/libidn/files/libidn-1.33-parallel-make.patch
index a33cdc74e2ae..95a58b2ff690 100644
--- a/net-dns/libidn/files/libidn-1.33-parallel-make.patch
+++ b/net-dns/libidn/files/libidn-1.33-parallel-make.patch
@@ -24,3 +24,92 @@ index 6832c20..218d52e 100644
--
1.9.1
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1,7 +1,7 @@
+-# Makefile.in generated by automake 1.14.1 from Makefile.am.
++# Makefile.in generated by automake 1.15.1 from Makefile.am.
+ # @configure_input@
+
+-# Copyright (C) 1994-2013 Free Software Foundation, Inc.
++# Copyright (C) 1994-2017 Free Software Foundation, Inc.
+
+ # This Makefile.in is free software; the Free Software Foundation
+ # gives unlimited permission to copy and/or distribute it,
+@@ -34,7 +34,17 @@
+
+
+ VPATH = @srcdir@
+-am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
++am__is_gnu_make = { \
++ if test -z '$(MAKELEVEL)'; then \
++ false; \
++ elif test -n '$(MAKE_HOST)'; then \
++ true; \
++ elif test -n '$(MAKE_VERSION)' && test -n '$(CURDIR)'; then \
++ true; \
++ else \
++ false; \
++ fi; \
++}
+ am__make_running_with_option = \
+ case $${target_option-} in \
+ ?) ;; \
+@@ -99,8 +109,6 @@
+ host_triplet = @host@
+ bin_PROGRAMS = idn$(EXEEXT)
+ subdir = src
+-DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
+- $(top_srcdir)/build-aux/depcomp $(dist_lisp_DATA)
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/lib/gl/m4/ctype.m4 \
+ $(top_srcdir)/lib/gl/m4/gnulib-comp.m4 \
+@@ -184,6 +192,8 @@
+ $(top_srcdir)/m4/wint_t.m4 $(top_srcdir)/configure.ac
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
++DIST_COMMON = $(srcdir)/Makefile.am $(dist_lisp_DATA) \
++ $(am__DIST_COMMON)
+ mkinstalldirs = $(install_sh) -d
+ CONFIG_HEADER = $(top_builddir)/config.h
+ CONFIG_CLEAN_FILES =
+@@ -294,6 +304,8 @@
+ done | $(am__uniquify_input)`
+ ETAGS = etags
+ CTAGS = ctags
++am__DIST_COMMON = $(srcdir)/Makefile.in \
++ $(top_srcdir)/build-aux/depcomp
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ ACLOCAL = @ACLOCAL@
+ ALLOCA = @ALLOCA@
+@@ -863,6 +875,7 @@
+ LT_AGE = @LT_AGE@
+ LT_CURRENT = @LT_CURRENT@
+ LT_REVISION = @LT_REVISION@
++LT_SYS_LIBRARY_PATH = @LT_SYS_LIBRARY_PATH@
+ MAKEINFO = @MAKEINFO@
+ MANIFEST_TOOL = @MANIFEST_TOOL@
+ MKDIR_P = @MKDIR_P@
+@@ -1200,7 +1213,6 @@
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu src/Makefile'; \
+ $(am__cd) $(top_srcdir) && \
+ $(AUTOMAKE) --gnu src/Makefile
+-.PRECIOUS: Makefile
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ @case '$?' in \
+ *config.status*) \
+@@ -1562,10 +1574,13 @@
+ pdf pdf-am ps ps-am tags tags-am uninstall uninstall-am \
+ uninstall-binPROGRAMS uninstall-dist_lispDATA
+
++.PRECIOUS: Makefile
++
+
+ idn.c: $(BUILT_SOURCES)
+
+-idn_cmd.c idn_cmd.h: idn.ggo Makefile.am
++# pattern rule (%) needed for parallel make (-j)
++idn_cmd%c idn_cmd%h: idn.ggo Makefile.am
+ gengetopt --unamed-opts --no-handle-version --no-handle-help \
+ --set-package="idn" \
+ --input $^ --file-name idn_cmd