summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-30 20:04:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-30 20:05:27 +0100
commit44eaa7f81365ae42635ca3fa6b82681d211b2cf7 (patch)
treef0ec094fc15a80b3feba5166812e7a9f5400715f /net-dns/nsd
parentdev-libs/libfilezilla: Removed old. (diff)
downloadgentoo-44eaa7f81365ae42635ca3fa6b82681d211b2cf7.tar.gz
gentoo-44eaa7f81365ae42635ca3fa6b82681d211b2cf7.tar.bz2
gentoo-44eaa7f81365ae42635ca3fa6b82681d211b2cf7.zip
net-dns/nsd: Bump to version 4.1.18
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.1.18.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index b72cf6904af4..1dc776ef4be3 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,2 +1,3 @@
DIST nsd-4.1.16.tar.gz 1088633 SHA256 7f8367ad23cc5cddffa885e7e2f549123c8b4123db9726df41d99f255d6baab2 SHA512 51135bbf412cdc5d6d9be02af9fef16513f0529155c102debfd6bd68b025d289c684777a8fca57de86b25f68bc94aef89d2cfefb871b8d63048d262f6c8eb8e3 WHIRLPOOL 030da2551abef8cb29e16574155605eb9377836f1a43422e200ba5bc6ede319893d4293018cf0be242d1ac0cfad4c3b40f566c7ad587792186c64102d8c9785f
DIST nsd-4.1.17.tar.gz 1089526 SHA256 107fa506d18ed6fd0a922d1b96774afd9270ec38ec6b17cd7c46fb9433a03a6c SHA512 4cffa261b1832d0daac095e92542359ffd725918f07ec605c78a9346b1cf4a4bc21bdc59ab388eb7324a170bbd8b122cfa75e7448015b38572b47d18add24a8f WHIRLPOOL c8892dca5f5c625d435cfde3f556ccc7518f3e37b7242892f9c101f4ffa5da1a2ea09083a30942bb1dad91ab70b40b2647339b2a4988f08478db9b6dd2b1c3df
+DIST nsd-4.1.18.tar.gz 1095673 BLAKE2B e3dc86e64614323dbefb334769a8095dc674f422f8e62c91e2918f4622ceac0ebef7dec42d5a714b15ad2f3af368ba817239a0027d3a685abf603cf00e9fa9d1 SHA512 d9939b8813677127ccd3e87e709b27a8a4f96cc0221ab77563d9349cb6dd56ae39bb7349ede9aed9aaa07de9310bcaeb8be8b17f608e9c4714b4fb084f2e756f
diff --git a/net-dns/nsd/nsd-4.1.18.ebuild b/net-dns/nsd/nsd-4.1.18.ebuild
new file mode 100644
index 000000000000..4a7e4dbabe2b
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.18.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_rc/rc}"
+MY_PV="${MY_PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ virtual/yacc
+ libevent? ( dev-libs/libevent )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ munin? ( net-analyzer/munin )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+
+src_prepare() {
+ # Fix the paths in the munin plugin to match our install
+ eapply "${FILESDIR}"/nsd_munin_.patch
+ eapply_user
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-pie
+ --enable-relro-now
+ --enable-largefile
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED%/}"/run || die "Failed to remove /run"
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}