summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-31 10:42:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-31 10:44:28 +0200
commit97c7434f63ce603ca88cbb50cc42ff343ef03960 (patch)
treee7d32312c70796e8dcd07c790c88da9777329f4d /net-dns/nsd
parentsys-libs/gdbm: Removed old. (diff)
downloadgentoo-97c7434f63ce603ca88cbb50cc42ff343ef03960.tar.gz
gentoo-97c7434f63ce603ca88cbb50cc42ff343ef03960.tar.bz2
gentoo-97c7434f63ce603ca88cbb50cc42ff343ef03960.zip
net-dns/nsd: Security bump to version 4.1.23
Bumped straight to stable. Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.1.23.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 451a94255386..5cbf0856149a 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,2 +1,3 @@
DIST nsd-4.1.21.tar.gz 1099021 BLAKE2B 129fd3145308c108ef2bd06b854aaf7cdb7ae7cce7a635c2028d210f87bc9591c89d8724b4d7a23d72e06e2ed73287c1379573f8cb3571cc63a47987db4f6b65 SHA512 1e37f433ff5cd4869145a575a89d6eaca6b17c0e029302e233277b400c5f0f0b76ea018d48178d6b8a75b72328f0ded9e885be836c0bb32367d6861ff11c7150
DIST nsd-4.1.22.tar.gz 1099463 BLAKE2B 955973e9ee01c1a5ed0a7cff38f881c775785b17452538db468f874d032b426a197b3709693c2df148de4a0f87259754b64c7ea02e53d9d96974f8c723267e19 SHA512 cab025b80955a15d174592ba5f0955c59333a988bf11b094c166a80206b51b6fcef65e2e976cd77009bf3fded257719efa4674a3a3a9d859ebc14e35fca2ecfb
+DIST nsd-4.1.23.tar.gz 1102038 BLAKE2B 673146931421ba7be5e90b6f60db23f9e61f42687e4f0aac2d6624125f09067dab535a3badfd00d795a3948319467f3924ca24cc0697b0c203591c2d6efb1834 SHA512 7eb44658be6a3b94855d1a84201e5f20a02c8d85786ac0b1f82a3a67e6bc3c22602d03a8976c2bcb68ea68f0bcf72f1d9fe688e1fd1f9fbe6a774c97bdcf7939
diff --git a/net-dns/nsd/nsd-4.1.23.ebuild b/net-dns/nsd/nsd-4.1.23.ebuild
new file mode 100644
index 000000000000..85ea02fc2f0b
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.23.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ libevent? ( dev-libs/libevent )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ munin? ( net-analyzer/munin )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED%/}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}