summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-01-28 16:45:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-01-28 16:46:26 +0100
commita27323c9c5ee56359c8a3418dd2b83df0ba4c896 (patch)
tree5ffc4c83173793d76e0558b38757394a63094ac3 /net-dns/nsd
parentnet-dns/nsd: Add live ebuild (diff)
downloadgentoo-a27323c9c5ee56359c8a3418dd2b83df0ba4c896.tar.gz
gentoo-a27323c9c5ee56359c8a3418dd2b83df0ba4c896.tar.bz2
gentoo-a27323c9c5ee56359c8a3418dd2b83df0ba4c896.zip
net-dns/nsd: Fixed build with USE="-ssl"
Closes: https://bugs.gentoo.org/832213 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/files/nsd-4.3.9-no_ssl.patch22
-rw-r--r--net-dns/nsd/nsd-4.3.9.ebuild4
2 files changed, 25 insertions, 1 deletions
diff --git a/net-dns/nsd/files/nsd-4.3.9-no_ssl.patch b/net-dns/nsd/files/nsd-4.3.9-no_ssl.patch
new file mode 100644
index 000000000000..33553a0ec889
--- /dev/null
+++ b/net-dns/nsd/files/nsd-4.3.9-no_ssl.patch
@@ -0,0 +1,22 @@
+From c5e6a8e5e566380c8c6731e9feb7ac686a1c0735 Mon Sep 17 00:00:00 2001
+From: "W.C.A. Wijngaards" <wouter@nlnetlabs.nl>
+Date: Fri, 28 Jan 2022 16:38:53 +0100
+Subject: [PATCH] - Fix #206: build with --without-ssl fails.
+
+diff --git a/edns.c b/edns.c
+index c7fc39d9..478ec681 100644
+--- a/edns.c
++++ b/edns.c
+@@ -21,6 +21,12 @@
+ #include "nsd.h"
+ #include "query.h"
+
++#if !defined(HAVE_SSL) || !defined(HAVE_CRYPTO_MEMCMP)
++/* we need fixed time compare, pull it in from tsig.c */
++#define CRYPTO_memcmp memcmp_fixedtime
++int memcmp_fixedtime(const void *s1, const void *s2, size_t n);
++#endif
++
+ void
+ edns_init_data(edns_data_type *data, uint16_t max_length)
+ {
diff --git a/net-dns/nsd/nsd-4.3.9.ebuild b/net-dns/nsd/nsd-4.3.9.ebuild
index 77567aaed614..e4f824b01061 100644
--- a/net-dns/nsd/nsd-4.3.9.ebuild
+++ b/net-dns/nsd/nsd-4.3.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,6 +45,8 @@ BDEPEND="
PATCHES=(
# Fix the paths in the munin plugin to match our install
"${FILESDIR}"/nsd_munin_.patch
+
+ "${FILESDIR}/${P}-no_ssl.patch" #832213
)
src_prepare() {