summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-22 01:51:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-22 01:53:12 +0100
commitb08500467fe482f9c94f2452c0abb26873665f4c (patch)
tree9e70bbbbc1d3d894b3f8cc09a1e80b9acaae36e7 /net-dns/nsd
parentsci-libs/ceres-solver: Drop USE c++11 (diff)
downloadgentoo-b08500467fe482f9c94f2452c0abb26873665f4c.tar.gz
gentoo-b08500467fe482f9c94f2452c0abb26873665f4c.tar.bz2
gentoo-b08500467fe482f9c94f2452c0abb26873665f4c.zip
net-dns/nsd: Bump to version 4.3.0
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.3.0.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 38ccddbe9361..85609fbdd7e6 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,3 +1,4 @@
DIST nsd-4.2.2.tar.gz 1149182 BLAKE2B 1cbac527063f7d14da589bd5060117da10fdd6a9e34b04eb763dbb94fe6c9cf09dc351985de3d099aea3377a4c945622871566c06e7f78aede885aa0c2bc5937 SHA512 43e2ee980a11ed0ad521cc9d8be1e2d29fa8ab552bdda043ffa7e5bc71cf07ad49319629f71e93dcf1dabd315f93bcfb9fd8b5847f27b125cf151fb4f63779b2
DIST nsd-4.2.3.tar.gz 1148054 BLAKE2B 1e184a557b973af24620338c2f4c94d27ecbd544dd40ee11c7905dc8304f6a1f7ba6d3e8ec49057ef88243d8afb9c005adba89e464ebecdd8b2ab2e5a751c302 SHA512 08349375caf96d870a7ba6e8de6342794f4bba356ef75d46f3c3f50462d356317f3e82a252febda21e2fbfe36bf7ad0c53f40079779faf204a4aaebd41fdc965
DIST nsd-4.2.4.tar.gz 1148826 BLAKE2B e2508c225d0bebeb9134c6eb3f00dfaf00d2de1a545cf9719b3bf04de8cf4a173ed744ebe5ff50a7062f5fb3135f4e476b9111736442fa358eb6ce20faac8406 SHA512 5d4f546a2a4484b182c65d3337d44596e935bca074c0eda2947b9d128a56db08a00240c6ec9ce22bc9a436e009c00c3283c4a5cbd1163ca4a429eaa92ec54208
+DIST nsd-4.3.0.tar.gz 1168198 BLAKE2B 87eb68987dfff84f7ab3038e8c563724d2859e61d28238967d5db272f6783f026eaa3729b73bd16761b8218110bdac7d636307babdaf67b9d35ddeb013ab5ae8 SHA512 8724fdfe9ca07dce6cf73bd0441a5d6b6e8a37f31744aca185e8cff2bde66ba677c189bb0b5bd8c8ec5682cd623bf24c0087ae47630615292b96d89f1d4134c5
diff --git a/net-dns/nsd/nsd-4.3.0.ebuild b/net-dns/nsd/nsd-4.3.0.ebuild
new file mode 100644
index 000000000000..b6ca20a489b4
--- /dev/null
+++ b/net-dns/nsd/nsd-4.3.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}