summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2018-11-09 14:57:53 +0000
committerSven Wegener <swegener@gentoo.org>2018-11-09 14:58:28 +0000
commit8c77868f620f6d6aacd63dc73172086cab5d00b2 (patch)
tree3755875afe84340831dbd0d30b00d7c60a043af5 /net-dns/pdns-recursor
parentdev-util/meson: 0.48.2 bump (diff)
downloadgentoo-8c77868f620f6d6aacd63dc73172086cab5d00b2.tar.gz
gentoo-8c77868f620f6d6aacd63dc73172086cab5d00b2.tar.bz2
gentoo-8c77868f620f6d6aacd63dc73172086cab5d00b2.zip
net-dns/pdns-recursor: Version bump
This release contains a different fix for CVE-2018-14644, with relaxed EDNS compliance requirements. Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.1.7.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 95c9e72d3b7e..b0126798b30f 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,3 +1,4 @@
DIST pdns-recursor-4.0.8.tar.bz2 1071831 BLAKE2B d9ab0dada8efa4b05c136650b9a2eab3aec4acab28ffb6da5bb4f627dc085b2c2d046d1f0dac5cf6e7054b47d76b8d7b95f56cc096b613891a4422b77e9abe9d SHA512 9886fccd3042904b7133e03a7b45479c8f2f57ecb33e4a043703b5e84816cd04a331503870e16030c86b353c1e14d9283dba767c1247e46ed6e14b7e0e93a5ef
DIST pdns-recursor-4.1.4.tar.bz2 1224360 BLAKE2B ddfa4f8c6a4534ef41dcb2e5341a9eece84a44a5a77f1f8cdd251a84888d428283a1396de74e9b50239f0663c05fa60fe36b2a4fb44689215518ea390584501e SHA512 1904685dfdcd69d4b85c4c70559d51cc8ef288551ffd8f93a96108c3aca4e46ec3950f93840e4bd39da00c63129033b5a541beb68d1e924d477b5b0abbf1d00c
DIST pdns-recursor-4.1.6.tar.bz2 1238122 BLAKE2B d33975498a10ea89f4cbc44321845ddee4773056dcb596257a94212e85079869c02dc8dcfd9d976802444b0327ae7a74b5e7bb2260a991e57732d41de3e9a819 SHA512 f55bf7dfb540f21fc4f8d19c41506512a760772a4ccf3f95446f6b57962cd175002c0455f7fdeaf0a8b29d3eda35e4a38cba3ce94422c5ca0115b640d0c0b806
+DIST pdns-recursor-4.1.7.tar.bz2 1237866 BLAKE2B f87263c0b4c40c8d5822edd75b338fc23609fb648c71b0665fc3cfd6b1d54679884dcdcc196580ab663f4fdeafaa72bee41308e3720b50374f2dfeb425259b6f SHA512 eb119b0da034624a95aadd4800e376b80f69b7151e773437c0f644bdc5a38a377c5547bcd57606367e148eaddf0b7de8f5f5ff3ab582b50ceb190f2fada5980a
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.1.7.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.1.7.ebuild
new file mode 100644
index 000000000000..2d88183b4f62
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.1.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl luajit protobuf snmp sodium systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_enable sodium libsodium) \
+ $(use_with !luajit lua) \
+ $(use_with luajit luajit) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}