summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-04-04 14:01:20 +0200
committerSven Wegener <swegener@gentoo.org>2022-04-04 14:01:43 +0200
commitc370ac03c3cfa11c1a9899a50e0068d5d2b5d7ce (patch)
treeff97e1eb4fbac92ae6b91eae124dcbff735fbc37 /net-dns/pdns-recursor
parentnet-misc/yandex-disk: version bump (diff)
downloadgentoo-c370ac03c3cfa11c1a9899a50e0068d5d2b5d7ce.tar.gz
gentoo-c370ac03c3cfa11c1a9899a50e0068d5d2b5d7ce.tar.bz2
gentoo-c370ac03c3cfa11c1a9899a50e0068d5d2b5d7ce.zip
net-dns/pdns-recursor: Version bump to.4.6.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-4.6.2-parseACL.patch24
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.6.2.ebuild92
3 files changed, 117 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 440508da8a66..9d82f3024287 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1 +1,2 @@
DIST pdns-recursor-4.6.1.tar.bz2 1541000 BLAKE2B fede4f654cd9900780df8dcc39585e95d8b0536c6d14476fde6f33a2d307144f50fb7b51bf6e0c950dcaff74120a101effee0c92cf15c4acedfa94a2682b0c5c SHA512 b595dd382bb4bff5cd47bff854952c8ee40bedeafe4236f935c8eceeca7ac97e8668b884e1ec0ce490ce535fab10d161ffc53ca395c0bb02ffcf6005a692674b
+DIST pdns-recursor-4.6.2.tar.bz2 1552587 BLAKE2B 3e7fe59ebe9d776c012304fc1bf6ed723c1c15df0aaedcaa8ac538741e81c5b6ebac2528e763e1395a0ea383904e4a902319509580938caae85b3aef947cfc3d SHA512 20779a065720162f0a6223a4d92deeef7911892bb8aa1929f9c6a8a6ccd2f8756e7bd35c877dbf945bb7627a2a7d40626d02f0008c2e8a602b424d36c110fddc
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-4.6.2-parseACL.patch b/net-dns/pdns-recursor/files/pdns-recursor-4.6.2-parseACL.patch
new file mode 100644
index 000000000000..ee58e055f09a
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-4.6.2-parseACL.patch
@@ -0,0 +1,24 @@
+--- a/pdns_recursor.cc
++++ b/pdns_recursor.cc
+@@ -4775,8 +4775,6 @@ static std::shared_ptr<NetmaskGroup> parseACL(const std::string& aclFile, const
+ result->addMask(line);
+ }
+ g_log<<Logger::Info<<"Done parsing "<<result->size()<<" "<<aclSetting<<" ranges from file '"<<::arg()[aclFile]<<"' - overriding '"<<aclSetting<<"' setting"<<endl;
+-
+- return result;
+ }
+ else if(!::arg()[aclSetting].empty()) {
+ vector<string> ips;
+@@ -4790,11 +4788,9 @@ static std::shared_ptr<NetmaskGroup> parseACL(const std::string& aclFile, const
+ g_log<<Logger::Info<<*i;
+ }
+ g_log<<Logger::Info<<endl;
+-
+- return result;
+ }
+
+- return nullptr;
++ return result;
+ }
+
+ void parseACLs()
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.6.2.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.6.2.ebuild
new file mode 100644
index 000000000000..fff451a76927
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.6.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ elibc_glibc? (
+ arm? ( >=sys-libs/glibc-2.34 )
+ x86? ( >=sys-libs/glibc-2.34 )
+ )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:=[context]"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parseACL.patch
+)
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}