summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2019-05-21 14:46:37 +0000
committerSven Wegener <swegener@gentoo.org>2019-05-21 14:47:12 +0000
commitcaec33fad3e870c7335211afcb16c9cf02f73981 (patch)
tree30f4d1177ff8521c569bd24462cf21fd15d5cf51 /net-dns/pdns-recursor
parentnet-wireless/unifi: bump to 5.10.24 (diff)
downloadgentoo-caec33fad3e870c7335211afcb16c9cf02f73981.tar.gz
gentoo-caec33fad3e870c7335211afcb16c9cf02f73981.tar.bz2
gentoo-caec33fad3e870c7335211afcb16c9cf02f73981.zip
net-dns/pdns-recursor: Version bump
Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.1.13.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 4a803d1b5423..d631555cc5b0 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.1.11.tar.bz2 1239986 BLAKE2B 33c9b2a2f811c43b67ad2bddf5a11d5d95cc88679d46ba3513f3eeec97bf7694af493a9fea4f733f003056b5f0fc971112e9062883324102ecca28838e2f3e41 SHA512 6041d31f0a517786f44a7fa22c7bfa94d5d4bdc3a7f349d2b47bc66be87404fe8eaf76f45ca18ef8ab96a45c0271f46fdba93a51fbda2542a3ad96e10f51c1d1
DIST pdns-recursor-4.1.12.tar.bz2 1245110 BLAKE2B 187fe117ab64f234d144d7e2d91a119afe1d6b0a45079f1f9527724081c64f594c8c5d5b4dbc6e25b4beef1fcdfb3e5caed8e5a434921bf6b66e07617d0fb6f9 SHA512 d228976937ede7e9f6b3375e573f5b436d9df7ae246e411b13acb095a1a58f12173b663acc364ce0fbdcc61b3d5522e101472a88da8f044e44541564f9915d9e
+DIST pdns-recursor-4.1.13.tar.bz2 1246775 BLAKE2B ec664baa9d98dde179f15777fb83817706770a88e08dfb61bf8bc9f1fcbd1e6e6064e44bda90da2d82ef4d15e33e0656cd6624c38b3922b5c662610085319164 SHA512 3b64caf291b80e1b0d024d607fc7e0fe8d51450a687a1090f0d0f7aab1a42a73fb31576a0acfddcee3f9c476f8bb0ac192a937f9c3481bef8031d34866b5f430
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.1.13.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.1.13.ebuild
new file mode 100644
index 000000000000..c054da53ceed
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.1.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl luajit protobuf snmp sodium systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_enable sodium libsodium) \
+ $(use_with !luajit lua) \
+ $(use_with luajit luajit) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}