summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-12-17 21:01:37 +0100
committerSven Wegener <swegener@gentoo.org>2020-12-17 21:06:37 +0100
commitf2f79745d83d9bb91206fc2b4ecb4015d62dec96 (patch)
tree8eba804683bdad38416bfe7dbdbb462f40632f77 /net-dns/pdns-recursor
parentkde-misc/tellico: Drop 3.3.4 (r0) (diff)
downloadgentoo-f2f79745d83d9bb91206fc2b4ecb4015d62dec96.tar.gz
gentoo-f2f79745d83d9bb91206fc2b4ecb4015d62dec96.tar.bz2
gentoo-f2f79745d83d9bb91206fc2b4ecb4015d62dec96.zip
net-dns/pdns-recursor: Version bump to 4.4.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.4.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 6b3bb38a30e1..632538496fdb 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,3 +1,4 @@
DIST pdns-recursor-4.3.5.tar.bz2 1341930 BLAKE2B 8f81182cb5283e6b8f459c5d23281d20cba02d22cec8776fdab67d452834b82945f467186c98784519d2c79d9df8438b174fc644fb11d68d04f9f636e51a5551 SHA512 2d39e6016000951c0beca38b26c41664b57c059dee762d7499f34e599ed6c2653af73edb31ba5a8d35f749534f24c0d85b6aedf4c35dc8a05777ffebd1b25851
DIST pdns-recursor-4.4.0.tar.bz2 1395544 BLAKE2B 3e963a0e481db0d96813d5aa43e231548d765ecf7c18ce777ab3e1fb4b057722b257ec59ae95bf5cb11cb2f9114eb0e087aebecd4b19b96519e9a1e9cf6bb307 SHA512 06ec7788510b656ee8e08e54d989d8789685a3acb8b11172aff5de21bff493227368bbfca8203c56853da97d209facc4d88005b4b565a5986788a1b5f16a9fb6
DIST pdns-recursor-4.4.1.tar.bz2 1395506 BLAKE2B 20a7b9612d03b96b92bab91b0281b08750221da06c56936c81fb4e1dccf83ca00f73bb7446523cd2a693b2774ee46ab673428cfdb4fc3f1702ef1e690a1112de SHA512 e5bdcf7f9b0095bd7169d605536e45beaa675cb9ac6e58280bf725535f1d3274dd4872418461ca5e216b310472ec08b8153c6da46d6ecf9ce545feb6ab3cd235
+DIST pdns-recursor-4.4.2.tar.bz2 1396763 BLAKE2B f8dad7694ac13ed8d824ddaf613d1a001452ab2c08fcbb0e00d2b2258464b754809746b89998b818c44866f9e4b22c87c1cebf2da852fb7b6247ac6b9fd4b99d SHA512 31fdf62d87e5ee8f9570c6b738339bc8cc65c43800f18c7fb49aa5c53fc9ad76a1ddf02cc44f7129e06b41700b5cb3768ff8f81cc521c28147ea6538c73f8781
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.4.2.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.4.2.ebuild
new file mode 100644
index 000000000000..7432ac3c647f
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.4.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap libressl luajit protobuf snmp sodium systemd"
+REQUIRED_USE="dnstap? ( protobuf )"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:0= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua=$(usex luajit luajit lua) \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}