summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-04-02 16:02:37 +0200
committerSven Wegener <swegener@gentoo.org>2022-04-02 16:08:44 +0200
commitfbcc363ce82b0b66f07e51825776e9a9a833aaad (patch)
tree532fe53a4a68dfc56182f23e62a0cd6c87d77ae9 /net-dns/pdns-recursor
parentdev-java/tomcat-servlet-api: Stabilize 8.5.76 arm64, #836622 (diff)
downloadgentoo-fbcc363ce82b0b66f07e51825776e9a9a833aaad.tar.gz
gentoo-fbcc363ce82b0b66f07e51825776e9a9a833aaad.tar.bz2
gentoo-fbcc363ce82b0b66f07e51825776e9a9a833aaad.zip
net-dns/pdns-recursor: Revision bump, bug #713746 and #836580
Closes: https://bugs.gentoo.org/713746 Closes: https://bugs.gentoo.org/836580 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-4.6.1-parseACL.patch13
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.6.1-r1.ebuild92
2 files changed, 105 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-4.6.1-parseACL.patch b/net-dns/pdns-recursor/files/pdns-recursor-4.6.1-parseACL.patch
new file mode 100644
index 000000000000..0d29a24f160f
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-4.6.1-parseACL.patch
@@ -0,0 +1,13 @@
+diff --git i/pdns_recursor.cc w/pdns_recursor.cc
+index 1700a9fde..ed09f2680 100644
+--- i/pdns_recursor.cc
++++ w/pdns_recursor.cc
+@@ -4844,7 +4844,7 @@ void parseACLs()
+
+ auto allowFrom = parseACL("allow-from-file", "allow-from");
+
+- if(allowFrom->size() == 0) {
++ if(allowFrom != nullptr && allowFrom->size() == 0) {
+ if(::arg()["local-address"]!="127.0.0.1" && ::arg().asNum("local-port")==53)
+ g_log<<Logger::Warning<<"WARNING: Allowing queries from all IP addresses - this can be a security risk!"<<endl;
+ allowFrom = nullptr;
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.6.1-r1.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..fff451a76927
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.6.1-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ elibc_glibc? (
+ arm? ( >=sys-libs/glibc-2.34 )
+ x86? ( >=sys-libs/glibc-2.34 )
+ )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:=[context]"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parseACL.patch
+)
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}