summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 20:10:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 00:20:53 +0100
commit88e7a2cd47f330509b884ff00de834d03cb5c7bb (patch)
treea3763049a5bbcb3c15b9c4b6a205c968b49cd86a /net-dns/resolv_wrapper
parentsci-geosciences/gmt: drop 4.5.18-r1, 6.3.0 (diff)
downloadgentoo-88e7a2cd47f330509b884ff00de834d03cb5c7bb.tar.gz
gentoo-88e7a2cd47f330509b884ff00de834d03cb5c7bb.tar.bz2
gentoo-88e7a2cd47f330509b884ff00de834d03cb5c7bb.zip
net-dns/resolv_wrapper: add 1.1.8
Upstream Changelog: "Fix issues with glibc >= 2.34" Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-dns/resolv_wrapper')
-rw-r--r--net-dns/resolv_wrapper/Manifest1
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-dns/resolv_wrapper/Manifest b/net-dns/resolv_wrapper/Manifest
index 5d399b55760b..8e6821cb9612 100644
--- a/net-dns/resolv_wrapper/Manifest
+++ b/net-dns/resolv_wrapper/Manifest
@@ -1 +1,2 @@
DIST resolv_wrapper-1.1.7.tar.gz 45148 BLAKE2B d1b860187bfa3be6eadd848abc458d5c9e3c4c4048a70b37d7548caf2604bda51f8a3606487fb95d682ab39e06f63f29b85de981ae32527997799fa5d72befab SHA512 531a7734f40d8a7cb3da4618eebbb4530657ad2cdcf3c1cd48f3ae1dcf55fc003205e44745fc3f70704060ae0c6a2516919c61fd10223ff56d90a47a3c59b3c0
+DIST resolv_wrapper-1.1.8.tar.gz 38051 BLAKE2B f9f4dee2d83a66d4efe911b9fc55ff1e06ad13fc876652416ce2c0cfa877d1be6b590bd322ad6b642a30a8d352bb3148ee79b5c1999b7ceedd338b711239cc34 SHA512 64cb722b3530b5669de1eba379ca4a577b505ac4be624d63a3988b16df2e3082489f48db099cba256dded9483ae913144b9a5c0c6e01af20da0709bd79c461c4
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild
new file mode 100644
index 000000000000..b47efa459a1b
--- /dev/null
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Wrapper for DNS name resolving or DNS faking"
+HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ dev-util/cmocka
+ net-libs/socket_wrapper
+ )"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir)
+ -DUNIT_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}