summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-12-08 22:56:51 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-12-08 22:56:51 -0500
commit0ff529d11297a320388902b62d95a92f231eb7be (patch)
tree585994318cd31580955e5547fad84a2a3c5fbd03 /net-dns/valtz
parentnet-dns/valtz: maintainer stabilize v0.8 on amd64 and x86. (diff)
downloadgentoo-0ff529d11297a320388902b62d95a92f231eb7be.tar.gz
gentoo-0ff529d11297a320388902b62d95a92f231eb7be.tar.bz2
gentoo-0ff529d11297a320388902b62d95a92f231eb7be.zip
net-dns/valtz: clean up old version and patches.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/valtz')
-rw-r--r--net-dns/valtz/Manifest1
-rw-r--r--net-dns/valtz/files/add-support-for-srv-records.patch83
-rw-r--r--net-dns/valtz/files/allow-underscores-in-records.patch48
-rw-r--r--net-dns/valtz/files/fix-generic-records-support.patch33
-rw-r--r--net-dns/valtz/valtz-0.7-r3.ebuild24
5 files changed, 0 insertions, 189 deletions
diff --git a/net-dns/valtz/Manifest b/net-dns/valtz/Manifest
index da366ca37532..0e0c8a2352d8 100644
--- a/net-dns/valtz/Manifest
+++ b/net-dns/valtz/Manifest
@@ -1,2 +1 @@
-DIST valtz-0.7.tgz 10638 BLAKE2B f6c8c476f523bc72531dd6537a7ed096b4fe15122db8ac8398b6ce325e8d61aecd3ef496c6102127bb8df4c8e0651201826ed4ccf79fd47616b6e083967412c4 SHA512 173e9f04399f8011b565ddfa7ad542c87af03da1b829d40b616271a993a282a1a3f54fb434db4837fb9ee4c3eb66a39f70ebf5ff5f13aff9c6fccfeabb3a3df7
DIST valtz-0.8.tar.xz 9644 BLAKE2B f5a102931fdd58e9ac85ff09f93243f76268cf3fd7c8cd3853b463115d292250293ca17e430ce93d0e7e5b78d90805126e24538b2f10bbf314a9ca0dbfd54d9f SHA512 87ad87445fb68b962b43e1d4cd08f155bdd3fe83480134dc141371bec87a2facce7f45381df655921e2875bb77c24bfb184487d8055f18a3acff50d8f4fa5c71
diff --git a/net-dns/valtz/files/add-support-for-srv-records.patch b/net-dns/valtz/files/add-support-for-srv-records.patch
deleted file mode 100644
index f8b9435c2ba8..000000000000
--- a/net-dns/valtz/files/add-support-for-srv-records.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 9d29c28941ca629e223d0d4f20a833f10375d331 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Thu, 5 Dec 2019 10:28:40 -0500
-Subject: [PATCH 2/3] Add support for SRV records.
-
-There is a patch for djbdns that adds support for SRV records to both
-tinydns-data and axfr-get:
-
- From: Michael Handler <handler@sub-rosa.com>
- To: dns@list.cr.yp.to
- Subject: tinydns-data SRV & axfr-get SRV/PTR patches
- Date: Thu, 14 Sep 2000 20:37:50 -040
-
-Many distributions carry the patch, but valtz rejects the SRV records
-because it doesn't recognize the "S" indicator or know how to validate
-the port, weight, or priority fields.
-
-This commit adds support for the new record type, and adds validation
-routines for the three new fields. All of them are the same: ports,
-weights, and priorities are all integers between 0 and 65536.
----
- valtz | 21 +++++++++++++++++++++
- 1 file changed, 21 insertions(+)
- mode change 100644 => 100755 valtz
-
-diff --git a/valtz b/valtz
-old mode 100644
-new mode 100755
-index eebda76..92aaa40
---- a/valtz
-+++ b/valtz
-@@ -100,6 +100,9 @@ my %token_name = (
- 'min' => 'Minimum time',
- 'n' => 'Record type number',
- 'rdata' => 'Resource data',
-+ 'port' => 'Port',
-+ 'priority' => 'Priority',
-+ 'weight' => 'Weight'
- );
-
- my %record_type = (
-@@ -114,6 +117,7 @@ my %record_type = (
- "'" => 'TXT',
- '^' => 'PTR',
- 'C' => 'CNAME',
-+ 'S' => 'SRV',
- 'Z' => 'SOA',
- ':' => 'GENERIC'
- );
-@@ -131,6 +135,8 @@ my %line_type = (
- "'" => [ 'TXT', 'fqdn:s:ttl:timestamp:lo', 'fqdn:s' ],
- '^' => [ 'PTR', 'fqdn:p:ttl:timestamp:lo', 'fqdn:p' ],
- 'C' => [ 'CNAME', 'fqdn:p:ttl:timestamp:lo', 'fqdn:p' ],
-+ 'S' => [ 'SRV', 'fqdn:ip:x:port:weight:priority:ttl:timestamp:lo',
-+ 'fqdn:x:port' ],
- 'Z' => [ 'SOA', 'fqdn:mname:rname:ser:ref:ret:exp:min:ttl:timestamp:lo',
- 'fqdn:mname:rname' ],
- ':' => [ 'GENERIC', 'fqdn:n:rdata:ttl:timestamp:lo', 'fqdn:n:rdata' ]
-@@ -340,6 +346,21 @@ my %token_validator = (
- # TODO : Validation needed?
- my $result = 0;
- return $result;
-+ }],
-+ 'port' => [ 21, sub {
-+ my ($type, $s) = @_;
-+ my $result = validate_integer($s, 65536);
-+ return $result;
-+ }],
-+ 'priority' => [ 22, sub {
-+ my ($type, $s) = @_;
-+ my $result = validate_integer($s, 65536);
-+ return $result;
-+ }],
-+ 'weight' => [ 23, sub {
-+ my ($type, $s) = @_;
-+ my $result = validate_integer($s, 65536);
-+ return $result;
- }],
-
-
---
-2.23.0
-
diff --git a/net-dns/valtz/files/allow-underscores-in-records.patch b/net-dns/valtz/files/allow-underscores-in-records.patch
deleted file mode 100644
index b76b231e6f15..000000000000
--- a/net-dns/valtz/files/allow-underscores-in-records.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 7c5df8ad5c18a9f8b9440dbd1ae4faacf55b452a Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Thu, 5 Dec 2019 10:34:54 -0500
-Subject: [PATCH 1/3] Allow underscore characters in FQDNs and pointers.
-
-Modern DNS records can contain underscores for a number of reasons. In
-particular, DKIM records involve a "_domainkey" part,
-
- https://tools.ietf.org/html/rfc6376
-
-that is rejected by the current "fqdn" and "p" validation routines.
-Moreover, any SRV records will have a service name prefixed with an
-underscore:
-
- https://tools.ietf.org/html/rfc2782
-
-To recognize these tokens as valid, this commit expands the "fqdn" and
-"p" regular expressions to allow underscores as the first character in
-each component of an FQDN.
----
- valtz | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/valtz b/valtz
-index c68c120..eebda76 100644
---- a/valtz
-+++ b/valtz
-@@ -202,7 +202,7 @@ my %token_validator = (
- # check all parts
- for my $hostpart (split /\./, $s)
- {
-- return 1005 unless $hostpart =~ /^[-a-z0-9]+$/i;
-+ return 1005 unless $hostpart =~ /^_?[-a-z0-9]+$/i;
- return 1006 if $hostpart =~ /^-/;
- return 1007 if $hostpart =~ /-$/;
- }
-@@ -268,7 +268,7 @@ my %token_validator = (
- # check all parts
- for (split /\./, $s)
- {
-- return 1005 unless /^[-[a-z0-9]+$/i;
-+ return 1005 unless /^_?[-[a-z0-9]+$/i;
- return 1006 if /^-/;
- return 1007 if /-$/;
- }
---
-2.23.0
-
diff --git a/net-dns/valtz/files/fix-generic-records-support.patch b/net-dns/valtz/files/fix-generic-records-support.patch
deleted file mode 100644
index b266340a471b..000000000000
--- a/net-dns/valtz/files/fix-generic-records-support.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-mjo: cherry-picked from https://github.com/wKovacs64/valtz
-
-From 422cc33cf0da52d10c271a75cda271d5963da4eb Mon Sep 17 00:00:00 2001
-From: wKovacs64 <justin.r.hall@gmail.com>
-Date: Tue, 16 Dec 2014 17:13:17 -0700
-Subject: [PATCH] Fix support for generic records
-
----
- valtz | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/valtz b/valtz
-index e9b831f..c68c120 100644
---- a/valtz
-+++ b/valtz
-@@ -75,7 +75,7 @@ my %validation_msg = (
- 1007 => 'parts must not end with the - character',
- 1008 => 'integer out of bounds',
- 1009 => 'must have at least three labels to be valid as mail address',
-- 1010 => 'must not 2(NS), 5(CNAME), 6(SOA), 12(PTR), 15(MX) or 252(AXFR)',
-+ 1010 => 'must not be 2(NS), 5(CNAME), 6(SOA), 12(PTR), 15(MX) or 252(AXFR)',
- );
-
- # NOTE : ONLY translate the right-hand part
-@@ -331,7 +331,7 @@ my %token_validator = (
- my ($type, $s) = @_;
- my $result = validate_integer($s, 65535);
-
-- return 1010 if ($s==2)||($s==5)||($s==6)||($s==12)||($s==15)||($s=252);
-+ return 1010 if ($s==2)||($s==5)||($s==6)||($s==12)||($s==15)||($s==252);
-
- return $result;
- }],
diff --git a/net-dns/valtz/valtz-0.7-r3.ebuild b/net-dns/valtz/valtz-0.7-r3.ebuild
deleted file mode 100644
index 131ff011aed8..000000000000
--- a/net-dns/valtz/valtz-0.7-r3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Validation tool for tinydns-data zone files"
-SRC_URI="https://x42.com/software/valtz/${PN}.tgz -> ${P}.tgz"
-HOMEPAGE="https://x42.com/software/valtz/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="dev-lang/perl"
-
-PATCHES=( "${FILESDIR}/fix-generic-records-support.patch"
- "${FILESDIR}/allow-underscores-in-records.patch"
- "${FILESDIR}/add-support-for-srv-records.patch" )
-
-src_install() {
- dobin valtz
- dodoc README CHANGES
-}