summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-30 21:13:47 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-11-01 22:55:06 +0100
commit321ef374ef1eb1270c8dbb14a7d48986afe6f8eb (patch)
tree009b437c84c128a2d8236ff65ec279f32ec29ef3 /net-dns
parentnet-im/sendxmpp: Port to EAPI 8 (diff)
downloadgentoo-321ef374ef1eb1270c8dbb14a7d48986afe6f8eb.tar.gz
gentoo-321ef374ef1eb1270c8dbb14a7d48986afe6f8eb.tar.bz2
gentoo-321ef374ef1eb1270c8dbb14a7d48986afe6f8eb.zip
net-dns/fpdns: Port to EAPI 8
Closes: https://bugs.gentoo.org/819348 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
index 41acf92d3609..69910304830a 100644
--- a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
+++ b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
@@ -1,33 +1,28 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch perl-module
+inherit perl-module
DESCRIPTION="Fingerprinting DNS servers"
HOMEPAGE="https://github.com/kirei/fpdns/"
-
MY_P="${PN}-${PV##*_pre}"
SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/"${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-perl/Net-DNS-0.74"
-S="${WORKDIR}"/"${MY_P}"
-
-src_prepare() {
- ## fixes https://github.com/kirei/fpdns/issues/6
- epatch "${FILESDIR}/${P}.ro-header.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}.ro-header.patch
+)
src_install() {
- newbin apps/fpdns fpdns
+ dobin apps/fpdns
insinto "${VENDOR_LIB}"/Net/DNS/
doins lib/Net/DNS/Fingerprint.pm
}