summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2018-07-16 13:53:52 +0200
committerChristian Ruppert <idl0r@gentoo.org>2018-07-16 13:54:12 +0200
commit3bbd728f594e54b03879747f0e03d5f4392d81a4 (patch)
tree45fa9938ed8c71bad4bbb31abb608fccc4dfb03a /net-dns
parentnet-dns/bind: Version bump (diff)
downloadgentoo-3bbd728f594e54b03879747f0e03d5f4392d81a4.tar.gz
gentoo-3bbd728f594e54b03879747f0e03d5f4392d81a4.tar.bz2
gentoo-3bbd728f594e54b03879747f0e03d5f4392d81a4.zip
net-dns/bind-tools: Version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/Manifest1
-rw-r--r--net-dns/bind-tools/bind-tools-9.12.2.ebuild146
-rw-r--r--net-dns/bind-tools/metadata.xml1
3 files changed, 148 insertions, 0 deletions
diff --git a/net-dns/bind-tools/Manifest b/net-dns/bind-tools/Manifest
index 3198b211c7cb..097b0b9538fe 100644
--- a/net-dns/bind-tools/Manifest
+++ b/net-dns/bind-tools/Manifest
@@ -1,2 +1,3 @@
DIST bind-9.11.2_p1.tar.gz 9783329 BLAKE2B 5a3bbd87112064231bd5e6b09ebb4014f9d5cf65cb601c03555ff540a22d87aec3990cd8e37ce5ff09e9a149bdf122d20ecb01f87731e6c79d80379a6926014f SHA512 168f27f580e3be2f7ada27afa2f72e715e750eec76831cf01bd32fabc1fa65dc29dab0eb7ed1682b076d3be99269897ddbc2c10551631a3911d9e5ae1aa40597
DIST bind-9.12.1.tar.gz 9302783 BLAKE2B 731ce67acb22f72e54de1122c5d5c3c1f0663c400bdff9545578a45e5fe3094c6d754351e57dd5c52cdfe1528305dfde25eba7382a723a60b8bfdfeebb9536cd SHA512 701e34a0a3313568c8e5cf76668fefc2a1fceb2ade0de201b8f678401569f1c622c3d1657a71772fa3298efc8b3cdefe974d98432c0087e8b45af3d50a4262fb
+DIST bind-9.12.2.tar.gz 9424960 BLAKE2B 85bb95568de0204da5bcf97555d659f3e2acd4b6f1c255586f1ca8552cdf734aa644406f7dabf64a8f2ce98980a5fbe011746011be7a8f4edf47ce2555cf2f55 SHA512 17b641138e4e9a878fe1c5843363eff090a8d2b056eb1f10eb4ff34e0e3f457990a4ab9e7136aca850641b6d92601088971d40b6976d105e57f61fcd5537dcbe
diff --git a/net-dns/bind-tools/bind-tools-9.12.2.ebuild b/net-dns/bind-tools/bind-tools-9.12.2.ebuild
new file mode 100644
index 000000000000..f4e0311bb53c
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.12.2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="https://www.isc.org/downloads/file/${MY_P}/?version=tar-gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc gost gssapi idn ipv6 libedit libidn2 libressl readline seccomp ssl urandom xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+REQUIRED_USE="gost? ( !libressl ssl )
+ idn? ( !libidn2 )
+ libidn2? ( !idn )"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ gost? ( >=dev-libs/openssl-1.0.0:0=[-bindist] )
+ xml? ( dev-libs/libxml2 )
+ idn? ( <net-dns/idnkit-2:= )
+ libidn2? ( net-dns/libidn2 )
+ gssapi? ( virtual/krb5 )
+ libedit? ( dev-libs/libedit )
+ !libedit? (
+ readline? ( sys-libs/readline:0= )
+ )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<net-dns/bind-9.10.2"
+
+S="${WORKDIR}/${MY_P}"
+
+# bug 479092, requires networking
+RESTRICT="test"
+
+src_prepare() {
+ # Disable tests for now, bug 406399
+ sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+ # bug #220361
+ rm aclocal.m4
+ rm -rf libtool.m4/
+
+ mv configure.in configure.ac || die # configure.in is deprecated
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 607400
+ if use libedit ; then
+ myconf+=' --with-readline=-ledit'
+ elif use readline ; then
+ myconf+=' --with-readline=-lreadline'
+ else
+ myconf+=' --without-readline'
+ fi
+
+ # bug 344029
+ append-cflags "-DDIG_SIGCHASE"
+
+ # localstatedir for nsupdate -l, bug 395785
+ tc-export BUILD_CC
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --without-python \
+ --without-libjson \
+ --without-zlib \
+ --without-lmdb \
+ $(use_enable ipv6) \
+ $(use_with idn idnkit) \
+ $(usex idn --with-idnlib=-lidnkit '') \
+ $(use_with libidn2) \
+ $(use_enable seccomp) \
+ $(use_with ssl openssl "${EPREFIX}"/usr) \
+ $(use_with xml libxml2) \
+ $(use_with gssapi) \
+ $(use_with readline) \
+ $(use_with gost) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ local AR=$(tc-getAR)
+
+ emake AR="${AR}" -C lib/
+ emake AR="${AR}" -C bin/delv/
+ emake AR="${AR}" -C bin/dig/
+ emake AR="${AR}" -C bin/nsupdate/
+ emake AR="${AR}" -C bin/dnssec/
+}
+
+src_install() {
+ dodoc README CHANGES
+
+ cd "${S}"/bin/delv
+ dobin delv
+ doman delv.1
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup
+ doman {dig,host,nslookup}.1
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate
+ doman nsupdate.1
+ if use doc; then
+ dohtml nsupdate.html
+ fi
+
+ cd "${S}"/bin/dnssec
+ for tool in dsfromkey importkey keyfromlabel keygen \
+ revoke settime signzone verify; do
+ dobin dnssec-"${tool}"
+ doman dnssec-"${tool}".8
+ if use doc; then
+ dohtml dnssec-"${tool}".html
+ fi
+ done
+}
diff --git a/net-dns/bind-tools/metadata.xml b/net-dns/bind-tools/metadata.xml
index 0db3429195ab..89bc2188b1f4 100644
--- a/net-dns/bind-tools/metadata.xml
+++ b/net-dns/bind-tools/metadata.xml
@@ -6,6 +6,7 @@
<name>Christian Ruppert</name>
</maintainer>
<use>
+ <flag name="libidn2">Enables IDN support using <pkg>net-dns/libidn2</pkg> rather than using <pkg>net-dns/idnkit</pkg></flag>
<flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
<flag name="gssapi">Enable gssapi support</flag>
<flag name="gost">Enables gost OpenSSL engine support</flag>