summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-09-15 15:02:40 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-10-15 14:41:21 +0200
commit60083b5e68554deee457092212c9ce11f7c9e360 (patch)
tree6f5fa64ccedf20b982a30e59fcaa6e1f0f3de121 /net-dns
parentapp-vim/vim-misc: clean up old. (diff)
downloadgentoo-60083b5e68554deee457092212c9ce11f7c9e360.tar.gz
gentoo-60083b5e68554deee457092212c9ce11f7c9e360.tar.bz2
gentoo-60083b5e68554deee457092212c9ce11f7c9e360.zip
net-dns/dnscrypt-proxy: version bump.
Also: * EAPI bump. * Switch to HTTPs. * Keyword for the arm platform. Closes: https://github.com/gentoo/gentoo/pull/2334 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-1.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index c886122c08c6..ae23f926c2ed 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -2,3 +2,4 @@ DIST dnscrypt-proxy-1.4.2.tar.gz 1592962 SHA256 1d519068c30868bb60a151908f0e300a
DIST dnscrypt-proxy-1.4.3.tar.gz 1560345 SHA256 f10f10c18e25ced3c5ec5d0c4145d33270f9cfa991fd1b18d5d9af00e4d9b68e SHA512 3aae9f20bc06087b0860a24488bcda117010a34218d7aef3c68a0f155f8164ce06a88865a9caf1ce5c5eaa8588518ccc2c8a61a97cc39f527f7b2b14cdf8c118 WHIRLPOOL 49915b0f95d340828c79febc9b7d94c4f0c444e016b9f78d134e05f43945b446ab71bbc6a230d6e15d5f1f4c0b97d9f671b6001314cc157cdcd419b01bf23550
DIST dnscrypt-proxy-1.6.0.tar.gz 1579293 SHA256 7703a41a1040fc30b19fdfbbaba36b411e66d998584b0e2fa5088f734f4f86be SHA512 1937a80ab0e6e5786b0d004fef1c007d9d8a4df335542ae6f96c1eac7739920f2ff4b469d30abac774c12a41d275c2a8bf31b5514d7af446028cedeeb3efcf02 WHIRLPOOL b24eb58bca1ff8fa55fec3836399a3ee5c66823d8b459e5f8ce7aa653454407dc3b80d7dc050b76e5c0595fc0e2d854478a6f949ef859b149f6b20e127c98274
DIST dnscrypt-proxy-1.6.1.tar.gz 1721006 SHA256 c519012a66f3ee30be02113d1e0139be08ccd2ec45ca4102eac35be731a65340 SHA512 8d49be73e4b2fe1131349846191f54c7f212ff301a6a6c2a77505225f81b0615e968c945013e732c4fce3b6090606245ec7343fb0d6145bb10b67dd4112d2367 WHIRLPOOL ca5a1c3792728ff54ee5e3c5a8815deb1ce2e1bdd016438ad0b84d89458064e0178df3c1dee77c8a685894092e48a305b521dc8e4bfc3cb40a0d7ac7e7e66d18
+DIST dnscrypt-proxy-1.7.0.tar.gz 1714401 SHA256 be9827f66401f38fd4bdb372046eff9b5802ab5f3d188878a0dcd7bd20074c09 SHA512 611d9cd9d9c086ec8e2b60f6c574451eae71ea07de85973049be7090cfbd8bf790d41f8a4a2b39d74091fba7091551967b93b85a8661c03ecad43d868df597a3 WHIRLPOOL 0c3902bfcc3571175f0f8638327cbaf5eada512565f214232732d14dc6a83f55a0babedd68007cbaeec1b584bcb1d3cc621df8b07638bacfe5893c6222d12997
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.7.0.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.7.0.ebuild
new file mode 100644
index 000000000000..65509ec82ec1
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
+HOMEPAGE="https://dnscrypt.org/"
+SRC_URI="https://download.dnscrypt.org/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+plugins systemd"
+
+CDEPEND="
+ dev-libs/libsodium
+ net-libs/ldns
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README* THANKS *txt"
+
+pkg_setup() {
+ enewgroup dnscrypt
+ enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_configure() {
+ econf \
+ $(use_enable plugins) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd-1.6.1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-1.6.0-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver <DNSCRYPT_LOCALIP>"
+ elog
+ elog "where <DNSCRYPT_LOCALIP> is what you supplied in"
+ elog "/etc/conf.d/dnscrypt-proxy, default is \"127.0.0.1\"."
+ elog
+ elog "Also see https://github.com/jedisct1/dnscrypt-proxy#usage."
+}