summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-10 21:39:23 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-10 21:43:53 +0200
commitaa8e967236b90655df2bfc796f14fc228e786f86 (patch)
treeac55fdb6366f4733499023a0e702f10fca4f9324 /net-dns
parentx11-misc/projecteur: drop old version (diff)
downloadgentoo-aa8e967236b90655df2bfc796f14fc228e786f86.tar.gz
gentoo-aa8e967236b90655df2bfc796f14fc228e786f86.tar.bz2
gentoo-aa8e967236b90655df2bfc796f14fc228e786f86.zip
net-dns/pdns: fix boost-1.73+ compatibility
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/files/pdns-4.3.0-boost-1.73-compatibility.patch57
-rw-r--r--net-dns/pdns/pdns-4.3.0.ebuild2
2 files changed, 59 insertions, 0 deletions
diff --git a/net-dns/pdns/files/pdns-4.3.0-boost-1.73-compatibility.patch b/net-dns/pdns/files/pdns-4.3.0-boost-1.73-compatibility.patch
new file mode 100644
index 000000000000..5975b09f0991
--- /dev/null
+++ b/net-dns/pdns/files/pdns-4.3.0-boost-1.73-compatibility.patch
@@ -0,0 +1,57 @@
+Fix compatibility with boost-1.73+
+
+Backport of https://github.com/PowerDNS/pdns/commit/71246536642590e8e8b21c11307ec4bd0e165066
+
+--- a/pdns/ixfrdist-web.cc
++++ b/pdns/ixfrdist-web.cc
+@@ -32,7 +32,7 @@ IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const Ne
+ {
+ d_ws->setACL(acl);
+ d_ws->setLogLevel(loglevel);
+- d_ws->registerWebHandler("/metrics", boost::bind(&IXFRDistWebServer::getMetrics, this, _1, _2));
++ d_ws->registerWebHandler("/metrics", std::bind(&IXFRDistWebServer::getMetrics, this, std::placeholders::_1, std::placeholders::_2));
+ d_ws->bind();
+ }
+
+--- a/pdns/webserver.cc
++++ b/pdns/webserver.cc
+@@ -107,7 +107,7 @@ static void bareHandlerWrapper(WebServer::HandlerFunction handler, YaHTTP::Reque
+
+ void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
+ {
+- YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
++ YaHTTP::THandlerFunction f = std::bind(&bareHandlerWrapper, handler, std::placeholders::_1, std::placeholders::_2);
+ YaHTTP::Router::Any(url, f);
+ }
+
+@@ -179,7 +179,7 @@ void WebServer::apiWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
+ }
+
+ void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
+- HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
++ HandlerFunction f = std::bind(&WebServer::apiWrapper, this, handler, std::placeholders::_1, std::placeholders::_2, allowPassword);
+ registerBareHandler(url, f);
+ }
+
+@@ -196,7 +196,7 @@ void WebServer::webWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
+ }
+
+ void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
+- HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
++ HandlerFunction f = std::bind(&WebServer::webWrapper, this, handler, std::placeholders::_1, std::placeholders::_2);
+ registerBareHandler(url, f);
+ }
+
+--- a/pdns/ws-auth.cc
++++ b/pdns/ws-auth.cc
+@@ -2328,8 +2328,8 @@ void AuthWebServer::webThread()
+ d_ws->registerApiHandler("/api", &apiDiscovery);
+ }
+ if (::arg().mustDo("webserver")) {
+- d_ws->registerWebHandler("/style.css", boost::bind(&AuthWebServer::cssfunction, this, _1, _2));
+- d_ws->registerWebHandler("/", boost::bind(&AuthWebServer::indexfunction, this, _1, _2));
++ d_ws->registerWebHandler("/style.css", std::bind(&AuthWebServer::cssfunction, this, std::placeholders::_1, std::placeholders::_2));
++ d_ws->registerWebHandler("/", std::bind(&AuthWebServer::indexfunction, this, std::placeholders::_1, std::placeholders::_2));
+ }
+ d_ws->go();
+ }
diff --git a/net-dns/pdns/pdns-4.3.0.ebuild b/net-dns/pdns/pdns-4.3.0.ebuild
index 97e6ee4740ad..e2c22a1c64b6 100644
--- a/net-dns/pdns/pdns-4.3.0.ebuild
+++ b/net-dns/pdns/pdns-4.3.0.ebuild
@@ -48,6 +48,8 @@ BDEPEND="virtual/pkgconfig
S="${WORKDIR}"/${P/_/-}
+PATCHES=( "${FILESDIR}"/${P}-boost-1.73-compatibility.patch )
+
src_configure() {
local dynmodules="pipe bind" # the default backends, always enabled