summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-17 15:20:50 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-17 15:50:07 +0200
commit07a5e9a24bf94ff5716dc764818fb72ef754ebed (patch)
tree8ae2916c296d1e2b74660652144a6f225140a609 /net-firewall/dshieldpy
parentmedia-sound/lilycomp: Drop old (diff)
downloadgentoo-07a5e9a24bf94ff5716dc764818fb72ef754ebed.tar.gz
gentoo-07a5e9a24bf94ff5716dc764818fb72ef754ebed.tar.bz2
gentoo-07a5e9a24bf94ff5716dc764818fb72ef754ebed.zip
net-firewall/dshieldpy: Bump eapi, use new eclasses, fix dependencies
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-firewall/dshieldpy')
-rw-r--r--net-firewall/dshieldpy/dshieldpy-3.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-firewall/dshieldpy/dshieldpy-3.2-r2.ebuild b/net-firewall/dshieldpy/dshieldpy-3.2-r2.ebuild
new file mode 100644
index 000000000000..d403c33ad2ed
--- /dev/null
+++ b/net-firewall/dshieldpy/dshieldpy-3.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python script to submit firewall logs to dshield.org"
+HOMEPAGE="http://dshieldpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dshieldpy/${P}.tar.gz"
+
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="${PYTHON_DEPEND}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/DShield.py"
+
+src_prepare() {
+ default
+ python_fix_shebang dshield.py
+}
+
+src_install() {
+ default
+ dobin dshield.py
+
+ insinto /etc
+ doins dshieldpy.conf
+}