summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-05-31 17:08:50 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-05-31 17:09:14 -0500
commit793b24acc338d0ee04959bced8ccea400f3b6cf1 (patch)
tree7f8654d60df1d32581fb1803b963c888efb2dadd /net-firewall/firewalld
parentnet-firewall/firewalld: drop old (diff)
downloadgentoo-793b24acc338d0ee04959bced8ccea400f3b6cf1.tar.gz
gentoo-793b24acc338d0ee04959bced8ccea400f3b6cf1.tar.bz2
gentoo-793b24acc338d0ee04959bced8ccea400f3b6cf1.zip
net-firewall/firewalld: version bump to 0.42, multiple fixes
This commit also fixes - bug #573648: incorrect path to iptables and family - bug #581760: update homepage - bug #566772: missing dependency dev-python/PyQt4 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-firewall/firewalld')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-0.4.2.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index 3273e4af6639..d211a6fe030f 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1,3 +1,4 @@
DIST firewalld-0.3.13.tar.bz2 561948 SHA256 bca88cbce4290b6959b3c0eea560e7f19c7cf2f563caca585b7db5cd2fca8ac9 SHA512 987ea3e243f87b8ded2f9627b4efc9649a22d878d19b6b760ba1a281e9e7280abcda558feebe6bd30e1cd27e7277a8ec99a7da623c29f04ab290c1d7ac3d6789 WHIRLPOOL 795f63fa5415c37ea9c6a835860dca4eb71879d1d69fcd6fbb022d0c4b4ab507d74e0e17098724846bd97246be3a98fab1d25134df69c9ac25db2fb77508b159
DIST firewalld-0.3.14.2.tar.bz2 617592 SHA256 4b6c3e1deab41b6002b8dc25639e466085941c98a6c14a56bef4f621a5651567 SHA512 18d57ca4501101b217b0854851f6bf18b5bd036e1e143ef1b3c2b97ef06e0cbb7399249f4904576381c9839a82ff51296f44f4520c7b221568c9e4518e593d8c WHIRLPOOL a00930a63dab654f64caac0deb5c24a28f5aa7c9882ca40bde642b9b765c9eeb81a582dcf015885b989543d4c85f6da6dc792c6532a844d87110bda2aa9a598f
DIST firewalld-0.4.0.tar.bz2 603881 SHA256 858dca878c65853dec9044e3531a7ee4cd00a1766c268c354eb3480fe6e14914 SHA512 7ebb220e919619927c72faa04f1831ff679fdaecec3dd66ba58222a83c235f53acdaf7ec5bb6fe17d782e5e22a2525abbe27a3e6c7d4e32b16be15dd5bca2b7e WHIRLPOOL c189c26f49798f623699583a1a7470834491ca36d79a7fb5e9e6affb1f98c83edc362fcb6ecef46a25bf24b4bcd5336963e2ff4b2c643d0ed7cf876991711d8c
+DIST firewalld-0.4.2.tar.bz2 649581 SHA256 329e44b7d8de2400222d602d6c87c368865531ffe4004c392803dbe55717068e SHA512 4e1ad32878393beaec70f91f462785c99464ce3ec610b68b20862af2bbb631b1bcffd0e68cff441944d5e272d63051dc783a7f5c0256c7a191e2340dab8f29a2 WHIRLPOOL 01b8928d9b570b70a358c68a2220712b329aace9c52905cc5420e9881575660c44b395d1b5f1ffc2550d74bcf42939db0a66fa9bdc02cb1d95959ab7a50072cd
diff --git a/net-firewall/firewalld/firewalld-0.4.2.ebuild b/net-firewall/firewalld/firewalld-0.4.2.ebuild
new file mode 100644
index 000000000000..112ffe527283
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.4.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+#BACKPORTS=
+
+inherit autotools eutils gnome2-utils python-r1 systemd multilib bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2
+ ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ --with-iptables="${EROOT}/sbin/iptables" \
+ --with-ip6tables="${EROOT}/sbin/ip6tables" \
+ --with-iptables_restore="${EROOT}/sbin/iptables-restore" \
+ --with-ip6tables_restore="${EROOT}/sbin/ip6tables-restore" \
+ --with-ebtables="${EROOT}/sbin/ebtables" \
+ --with-ebtables_restore="${EROOT}/sbin/ebtables-restore" \
+ "$(systemd_with_unitdir 'systemd-unitdir')" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ # manually split up the installation to avoid "file already exists" errors
+ emake -C config DESTDIR="${D}" install
+ emake -C po DESTDIR="${D}" install
+ emake -C shell-completion DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install
+
+ install_python() {
+ emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" install
+ python_optimize
+ }
+ python_foreach_impl install_python
+
+ python_replicate_script "${D}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
+ python_replicate_script "${D}/usr/sbin/firewalld"
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/"
+ rm -rf "${D}/etc/sysconfig/"
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -f "${D}/usr/bin/firewall-applet"
+ rm -f "${D}/usr/bin/firewall-config"
+ rm -rf "${D}/usr/share/icons"
+ rm -rf "${D}/usr/share/applications"
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}