summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-21 02:34:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-21 03:17:22 +0100
commit044483145e10ca245b8644d664eeebd95b2ca5d1 (patch)
tree324fcc460c2843849c8ec52c2fc069e7f95874ee /net-firewall/ipset
parentnet-firewall/ipset: use HTTPS for HOMEPAGE/SRC_URI (diff)
downloadgentoo-044483145e10ca245b8644d664eeebd95b2ca5d1.tar.gz
gentoo-044483145e10ca245b8644d664eeebd95b2ca5d1.tar.bz2
gentoo-044483145e10ca245b8644d664eeebd95b2ca5d1.zip
net-firewall/ipset: check for NETFILTER_NETLINK support in kernel
Closes: https://bugs.gentoo.org/704126 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ipset-7.10.ebuild2
-rw-r--r--net-firewall/ipset/ipset-7.11.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-firewall/ipset/ipset-7.10.ebuild b/net-firewall/ipset/ipset-7.10.ebuild
index fc8f87ec260b..e5cf531894f1 100644
--- a/net-firewall/ipset/ipset-7.10.ebuild
+++ b/net-firewall/ipset/ipset-7.10.ebuild
@@ -38,6 +38,8 @@ pkg_setup() {
get_version
CONFIG_CHECK="NETFILTER"
ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
+ CONFIG_CHECK+=" NETFILTER_NETLINK"
+ ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
# It does still build without NET_NS, but it may be needed in future.
#CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
#ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."
diff --git a/net-firewall/ipset/ipset-7.11.ebuild b/net-firewall/ipset/ipset-7.11.ebuild
index fc8f87ec260b..e5cf531894f1 100644
--- a/net-firewall/ipset/ipset-7.11.ebuild
+++ b/net-firewall/ipset/ipset-7.11.ebuild
@@ -38,6 +38,8 @@ pkg_setup() {
get_version
CONFIG_CHECK="NETFILTER"
ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
+ CONFIG_CHECK+=" NETFILTER_NETLINK"
+ ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
# It does still build without NET_NS, but it may be needed in future.
#CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
#ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."