summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-23 15:37:51 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-23 15:38:03 +0200
commit241cf6f81f8f531d86d7546e207bc133ad333964 (patch)
treed785fcbd6b617d953412e53841bbb88f0b48525f /net-firewall/ipt_netflow
parentnet-firewall/ipt_netflow: Version 2.4 (diff)
downloadgentoo-241cf6f81f8f531d86d7546e207bc133ad333964.tar.gz
gentoo-241cf6f81f8f531d86d7546e207bc133ad333964.tar.bz2
gentoo-241cf6f81f8f531d86d7546e207bc133ad333964.zip
net-firewall/ipt_netflow: Old
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-firewall/ipt_netflow')
-rw-r--r--net-firewall/ipt_netflow/Manifest1
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/net-firewall/ipt_netflow/Manifest b/net-firewall/ipt_netflow/Manifest
index 0f3902c58109..45893db3a07f 100644
--- a/net-firewall/ipt_netflow/Manifest
+++ b/net-firewall/ipt_netflow/Manifest
@@ -1,3 +1,2 @@
DIST ipt_netflow-2.3.tar.gz 90987 BLAKE2B fbe46583e58e75e3cfe5cc5ad4e8b40d5040d6642f850c560c3e8aa831effa43cba8f25907d32b3b66721f4d5d5bb8579bafa82e4b8d1c9a2225a5c748d08dd9 SHA512 e5ba66da9cae6fb9652e5532383233d433dd30dd16634734860f7e6910e46080e562e2d72c74584a86ead31156cffd4c5c44b438f617a9e5b3e5fdc1470045fc
-DIST ipt_netflow-2.3_p20190619.tar.gz 92615 BLAKE2B f6fb8e33d847a050e81edd33cc11b2088e59a838924f6f371489e219d7207afefa6211ac7d55aa54d8d1579fe95d9ec5302bb533a7cf11bdb3df8e2e7a2e5633 SHA512 0ac101d660bc37eab05bf079321edd9578f2fd3b09627f329fab4940c8e2d554a449673d557603dc33897fdd3f8a7b054ff2ceb7cc338b86176b3630f2b50cba
DIST ipt_netflow-2.4.tar.gz 92580 BLAKE2B 0197e7e5cdd9c94c7b80b38cb4e2879343139592421922bf73aeaac70ac3af54ea25934bb1474ff455a9f58eab2368995591542f46be48b5c8491a3b6a192f56 SHA512 3c80d02cfda996fbde8d258875df8795000fd8390b5a6f8296771a992067e153eca48f7f4602421529948beaf3030e164adfc2ffe5b528042fbdc15ffb56aa74
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
deleted file mode 100644
index 5f49f78b07df..000000000000
--- a/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit linux-info linux-mod toolchain-funcs
-
-DESCRIPTION="Netflow iptables module"
-HOMEPAGE="
- https://sourceforge.net/projects/ipt-netflow
- https://github.com/aabc/ipt-netflow
-"
-SRC_URI="https://github.com/aabc/ipt-netflow/archive/0e5af37bf63681ff4ee95b98466ee26fa3e4df13.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug natevents snmp"
-
-RDEPEND="
- net-firewall/iptables:0=
- snmp? ( net-analyzer/net-snmp )
-"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}/${PN}-2.0-configure.patch" # bug #455984
- "${FILESDIR}/${PN}-2.3-flags.patch"
-)
-
-pkg_setup() {
- BUILD_TARGETS="all"
- MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
- IPT_LIB="/usr/$(get_libdir)/xtables"
- local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
- use debug && CONFIG_CHECK+=" ~DEBUG_FS"
- use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- default
-
- mv "${WORKDIR}"/${PN/_/-}-* "${WORKDIR}"/${P} || die
-}
-
-src_prepare() {
- default
-
- # Fix incorrect module version in sources
- sed -i -e "/IPT_NETFLOW_VERSION/s/2.3/${PV}/" ipt_NETFLOW.c || die
-
- # Checking for directory is enough
- sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die
-}
-
-do_conf() {
- tc-export CC
- echo ./configure $*
- ./configure $* ${EXTRA_ECONF} || die 'configure failed'
-}
-
-src_configure() {
- local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
- # this configure script is not based on autotools
- # ipt-src need to be defined, see bug #455984
- do_conf \
- --disable-dkms \
- --enable-aggregation \
- --enable-direction \
- --enable-macaddress \
- --enable-vlan \
- --ipt-lib="${IPT_LIB}" \
- --ipt-src="/usr/" \
- --ipt-ver="${IPT_VERSION}" \
- --kdir="${KV_DIR}" \
- --kver="${KV_FULL}" \
- $(use debug && echo '--enable-debugfs') \
- $(use natevents && echo '--enable-natevents') \
- $(use snmp && echo '--enable-snmp-rules' || echo '--disable-snmp-agent')
-}
-
-src_compile() {
- emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
-}
-
-src_install() {
- linux-mod_src_install
- exeinto "${IPT_LIB}"
- doexe libipt_NETFLOW.so
- use snmp && emake DESTDIR="${D}" SNMPTGSO="/usr/$(get_libdir)/snmp/dlmod/snmp_NETFLOW.so" sinstall
- doheader ipt_NETFLOW.h
- dodoc README*
-}