summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 12:59:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 16:54:20 +0100
commit9d879855acc071405b2442bf5e221a39836221f1 (patch)
treeb3c53f1c9ba207fea6c2634ed28c1f0c4c71103a /net-firewall
parentnet-dns/hash-slinger: Switch to python-single-r1 (diff)
downloadgentoo-9d879855acc071405b2442bf5e221a39836221f1.tar.gz
gentoo-9d879855acc071405b2442bf5e221a39836221f1.tar.bz2
gentoo-9d879855acc071405b2442bf5e221a39836221f1.zip
net-firewall/fwknop: Switch to python-single-r1
Switch to python-single-r1 since the dependency net-firewall/firewalld is single-r1. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/fwknop/fwknop-2.6.10-r1.ebuild (renamed from net-firewall/fwknop/fwknop-2.6.10.ebuild)10
-rw-r--r--net-firewall/fwknop/fwknop-2.6.9-r1.ebuild10
2 files changed, 16 insertions, 4 deletions
diff --git a/net-firewall/fwknop/fwknop-2.6.10.ebuild b/net-firewall/fwknop/fwknop-2.6.10-r1.ebuild
index 41a07f7c1a83..52c57d2312c0 100644
--- a/net-firewall/fwknop/fwknop-2.6.10.ebuild
+++ b/net-firewall/fwknop/fwknop-2.6.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,6 +6,7 @@ EAPI=7
# Python extension supports only Python 2.
# See https://github.com/mrash/fwknop/issues/167
PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1 eutils linux-info readme.gentoo-r1 systemd
@@ -21,7 +22,7 @@ IUSE="+client extras firewalld gdbm gpg +iptables nfqueue python +server udp-ser
DEPEND="
client? ( net-misc/wget[ssl] )
- firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
+ firewalld? ( net-firewall/firewalld[${PYTHON_SINGLE_USEDEP}] )
gdbm? ( sys-libs/gdbm )
gpg? (
app-crypt/gpgme
@@ -54,6 +55,11 @@ You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
instead of the default one chosen at compile time.
"
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
src_prepare() {
default_src_prepare
diff --git a/net-firewall/fwknop/fwknop-2.6.9-r1.ebuild b/net-firewall/fwknop/fwknop-2.6.9-r1.ebuild
index 5c86df5bfb0c..03699570bd46 100644
--- a/net-firewall/fwknop/fwknop-2.6.9-r1.ebuild
+++ b/net-firewall/fwknop/fwknop-2.6.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,6 +7,7 @@ EAPI=6
# See https://github.com/mrash/fwknop/issues/167
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
+DISTUTILS_SINGLE_IMPL=1
inherit autotools distutils-r1 eutils linux-info readme.gentoo-r1 systemd
@@ -21,7 +22,7 @@ IUSE="+client extras firewalld gdbm gpg +iptables nfqueue python +server udp-ser
DEPEND="
client? ( net-misc/wget[ssl] )
- firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
+ firewalld? ( net-firewall/firewalld[${PYTHON_SINGLE_USEDEP}] )
gdbm? ( sys-libs/gdbm )
gpg? (
app-crypt/gpgme
@@ -54,6 +55,11 @@ You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
instead of the default one chosen at compile time.
"
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
src_prepare() {
default_src_prepare