summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-08-16 09:02:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-08-16 09:33:12 +0300
commitbcb3eb3a6657937f45b2c22b4a600557b7b29c9d (patch)
treef7da24463e46ada4a46de4e8def4d743776b8997 /net-firewall
parentnet-firewall/ufw: warn about possible conflicts (diff)
downloadgentoo-bcb3eb3a6657937f45b2c22b4a600557b7b29c9d.tar.gz
gentoo-bcb3eb3a6657937f45b2c22b4a600557b7b29c9d.tar.bz2
gentoo-bcb3eb3a6657937f45b2c22b4a600557b7b29c9d.zip
net-firewall/ufw: bashify the new check
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ufw/ufw-0.36.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-firewall/ufw/ufw-0.36.ebuild b/net-firewall/ufw/ufw-0.36.ebuild
index 0da5a40cfa58..ed4a7029034c 100644
--- a/net-firewall/ufw/ufw-0.36.ebuild
+++ b/net-firewall/ufw/ufw-0.36.ebuild
@@ -167,28 +167,28 @@ pkg_postinst() {
print_check_req_warn=false
local found=()
- local apps=("${CATEGORY}/arno-iptables-firewall"
- "${CATEGORY}/ferm"
- "${CATEGORY}/firehol"
- "${CATEGORY}/firewalld"
- "${CATEGORY}/ipkungfu")
+ local apps=( "net-firewall/arno-iptables-firewall"
+ "net-firewall/ferm"
+ "net-firewall/firehol"
+ "net-firewall/firewalld"
+ "net-firewall/ipkungfu" )
for exe in "${apps[@]}"
do
- if has_version ''"${exe}"''; then
+ if has_version "${exe}"; then
found+=( "${exe}" )
fi
done
- if [ -n "$found" ]; then
- echo
+ if [[ -n ${found} ]]; then
+ echo ""
ewarn "WARNING: Detected other firewall applications:"
ewarn "${found[@]}"
ewarn "If enabled, these applications may interfere with ufw!"
fi
if [[ -z "${REPLACING_VERSIONS}" ]]; then
- echo
+ echo ""
elog "To enable ufw, add it to boot sequence and activate it:"
elog "-- # rc-update add ufw boot"
elog "-- # /etc/init.d/ufw start"