summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-04-06 23:56:06 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-06 23:56:06 -0700
commitf103299fc4d3445f5e0f47b2aa4e43316500dfa3 (patch)
treec605c2d4b6f4abd7ecb8957fb635245f50b996f8 /net-firewall
parentwww-client/opera-developer: Old (diff)
downloadgentoo-f103299fc4d3445f5e0f47b2aa4e43316500dfa3.tar.gz
gentoo-f103299fc4d3445f5e0f47b2aa4e43316500dfa3.tar.bz2
gentoo-f103299fc4d3445f5e0f47b2aa4e43316500dfa3.zip
net-firewall/nftables-0.9.4-r1: revbump, call python_optimize, fix deps
Call python_optimize to fix QA warning about unoptimized python code. The docbook2X dep is only needed for building man pages, so put it under the doc USE flag. Fix the pkg_postinst message about systemd (bug #705308) Closes: https://bugs.gentoo.org/705308 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/nftables-0.9.4-r1.ebuild (renamed from net-firewall/nftables/nftables-0.9.4.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-firewall/nftables/nftables-0.9.4.ebuild b/net-firewall/nftables/nftables-0.9.4-r1.ebuild
index 1858322697d3..c6c7496044cf 100644
--- a/net-firewall/nftables/nftables-0.9.4.ebuild
+++ b/net-firewall/nftables/nftables-0.9.4-r1.ebuild
@@ -30,8 +30,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
- doc? ( app-text/asciidoc )
- >=app-text/docbook2X-0.8.8-r4
+ doc? (
+ app-text/asciidoc
+ >=app-text/docbook2X-0.8.8-r4
+ )
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
@@ -115,6 +117,7 @@ src_install() {
python_foreach_impl python_make install
fi
+ python_foreach_impl python_optimize
find "${ED}" -type f -name "*.la" -delete || die
}
@@ -136,7 +139,7 @@ pkg_postinst() {
elog "If you wish to enable the firewall rules on boot (on systemd) you"
elog "will need to enable the nftables-restore service."
- elog " 'systemd_enable_service basic.target ${PN}-restore.service'"
+ elog " 'systemctl enable ${PN}-restore.service'"
elog
elog "If you are creating firewall rules before the next system restart "
elog "the nftables-restore service must be manually started in order to "