summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-10 07:54:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-10 07:56:17 +0100
commit3e0d35af149c5a90556fd655456a2ba4e25fbaee (patch)
tree5142fc617b11dec759753db6a5588bb9c849d57f /net-fs/curlftpfs
parentnet-fs/curlftpfs: fix sys-fs/fuse SLOT (diff)
downloadgentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.tar.gz
gentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.tar.bz2
gentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.zip
net-fs/curlftpfs: modernize to EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-fs/curlftpfs')
-rw-r--r--net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild22
-rw-r--r--net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch4
-rw-r--r--net-fs/curlftpfs/files/curlftpfs-0.9.2-darwin.patch5
3 files changed, 16 insertions, 15 deletions
diff --git a/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
index ee8b52e0a00f..04a3efebf10f 100644
--- a/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
+++ b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="File system for accessing ftp hosts based on FUSE"
HOMEPAGE="http://curlftpfs.sourceforge.net/"
@@ -21,18 +21,20 @@ RDEPEND=">=net-misc/curl-7.17.0
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit_filesize.patch
+ "${FILESDIR}"/${PN}-0.9.2-darwin.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
+ "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-64bit_filesize.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-darwin.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-memleak.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
+ default
# automake-1.13.1 obsoletes AM_* bit #469818
sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
- epatch_user
-
eautoreconf
}
diff --git a/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch b/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch
index 38b6f33a2ba5..256c74923708 100644
--- a/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch
+++ b/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch
@@ -1,5 +1,5 @@
---- ftpfs.c.old 2009-11-28 14:28:05.000000000 +0300
-+++ ftpfs.c 2009-11-28 14:28:19.000000000 +0300
+--- a/ftpfs.c 2009-11-28 14:28:05.000000000 +0300
++++ b/ftpfs.c 2009-11-28 14:28:19.000000000 +0300
@@ -503,7 +503,7 @@
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
diff --git a/net-fs/curlftpfs/files/curlftpfs-0.9.2-darwin.patch b/net-fs/curlftpfs/files/curlftpfs-0.9.2-darwin.patch
index fd0bd1f0cfe5..81265920531b 100644
--- a/net-fs/curlftpfs/files/curlftpfs-0.9.2-darwin.patch
+++ b/net-fs/curlftpfs/files/curlftpfs-0.9.2-darwin.patch
@@ -1,8 +1,7 @@
https://sourceforge.net/tracker/?func=detail&atid=816359&aid=2799820&group_id=160565
-diff -ur configure.ac configure.ac
---- configure.ac 2008-04-23 15:37:42 +0400
-+++ configure.ac 2009-06-02 09:46:05 +0400
+--- a/configure.ac 2008-04-23 15:37:42 +0400
++++ b/configure.ac 2009-06-02 09:46:05 +0400
@@ -18,6 +18,11 @@
AC_MSG_ERROR(["We need libcurl with support for FTP protocol."])
fi