summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-06 15:23:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-06 15:26:41 +0200
commit0ed152fff699a2d0d8b17b3ad533cd6d8fe5d4c8 (patch)
treeb9adb9c23d81bbc143e2c5583d4652dca1e5cd08 /net-fs/libnfs/libnfs-9999.ebuild
parentmedia-plugins/vdr-live: version bump, fixed deprecated eapi (diff)
downloadgentoo-0ed152fff699a2d0d8b17b3ad533cd6d8fe5d4c8.tar.gz
gentoo-0ed152fff699a2d0d8b17b3ad533cd6d8fe5d4c8.tar.bz2
gentoo-0ed152fff699a2d0d8b17b3ad533cd6d8fe5d4c8.zip
net-fs/libnfs: live ebuild improvements.
- EAPI-6 bump - Add "utils" USE flag - Bump sub-slot to 12 to reflect .so version change Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'net-fs/libnfs/libnfs-9999.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 958c36a1dd24..96606a99d49c 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,42 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-AUTOTOOLS_AUTORECONF="1"
-
-inherit autotools autotools-utils eutils
+inherit autotools
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
+ S="${WORKDIR}/${PN}-${P}"
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/11" # sub-slot matches SONAME major
-IUSE="examples static-libs"
+SLOT="0/12" # sub-slot matches SONAME major
+IUSE="examples static-libs utils"
RDEPEND=""
DEPEND="${RDEPEND}
virtual/pkgconfig"
-S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-utils.patch"
+)
src_prepare() {
default
-
- epatch_user
-
eautoreconf
}
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable utils)
+ )
+ econf "${myeconfargs[@]}"
+}
+
src_install() {
- autotools-utils_src_install
+ default
if use examples; then
# --enable-examples configure switch just compiles them
# better install sources instead
@@ -45,4 +51,5 @@ src_install() {
doexe examples/${program}.c
done
fi
+ find "${ED}" -name "*.la" -delete || die
}